Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,506 Posts
Discussion Starter #1
Okay, I didn't want to do this...

But it's getting close to raceday and I'm slightly behind schedule. So if anyone near North Richland Hills is available to lend a hand with the SAAB, I would be forever in debt to you. I don't have beer, but I will pay for some if you want to get it. I do have food, cokes, etc.

I had a wreck in the SAAB Wednesday and have been working on it pretty much non-stop since Wednesday night. Still have to put the front end together and straighten the bumper (got the subframe straightened and ready to go). I'm looking at about 5 hours on my own at this point.

Phone: 817-907-2606

(Don't go out of your way, but if you're just sitting around bored I would appreciate any help I can get)
 

·
Registered
Joined
·
1,097 Posts
aaaaaaahhhhh I woulda helped ya if I'da seen this. I'm sorry man, I hope you got it worked out
 

·
Registered
Joined
·
1,506 Posts
Discussion Starter #3
I just finished. Thanks though! Wish me luck tomorrow!
 

·
Registered
Joined
·
183 Posts
Glad you got it done... I briefly considered it, but did not aid you for two reasons:
1.) I was having a bad wrenching day. Nothing worked properly, and everything that could go wrong, went wrong.
2.) I have to finish my truck before my dad gets back in town or he'll say three things. a.) it looks rediculous b.) youre wasting your money c.) youre done

So im sorry, but i am almost sure I would have caused you more pain than aid. My day turned out to be the worst day of wrenching ever...
 

·
Registered
Joined
·
1,542 Posts
Sorry I missed your post and couldn't help, but glad to hear you got it done in time. I was out yesterday helping another buddy with his Jeep. I'd love to go watch ya race today, but I'm heading over to another buddy's to help him with his Tacoma. Good luck at the races and post some pics if you can!
 

·
Registered
Joined
·
1,506 Posts
Discussion Starter #6
It's all good fellas. Thanks though! She was still running rough and I had to run with the wastegate actuator disconnected (naturally aspirated for all practical purposes), but I was still running fairly decent and went from 65 (or 62, I forget) seconds down to 57 flat. I got first in my class, and (according to the list posted at the end of the last runs) 3rd out of all the novice drivers.
I was satisfied with it, all things considered. I'm looking forward to running the next event with a fully-functional car and nabbing 45+ points (got 40 this round).

In case anyone's interested. The next event is Sunday May 7th (or 6th, whichever is Sunday) at Texas Motor Speedway in the bus parking lot.
 
1 - 6 of 6 Posts
Top