Bronco Forum - Full Size Ford Bronco Forum banner

21 - 32 of 32 Posts

·
Registered
1984, 300 L6, smogless, manual 3speed with overdrive.
Joined
·
1,394 Posts
If you can live without cruise control unhook that chain and see if that solves your issue, my CC on my dually was going out and self engaging disconnected it.
Alsos too.. check the end of the green piece (no not that one) the one thats inside the spring, it might be catching on the spring.
But the free hand test on the throttle cable would be my first test, it should slide freely.
 

·
Registered
82 XLT Lariat 351w, Edelbrock 1406 4bbl ,C6 auto, auto locking hubs ,33x10.5x15
Joined
·
2,163 Posts
Discussion Starter #22
The cruise currently isn't hooked up @MojoJojo . Will check ur other suggestions ? thanks ?
 

·
Registered
Joined
·
9,534 Posts
Do u think it would wear out in 2 years and 2000 miles?
Possible but unlikely. Your spring does look kinda odd though. Its narrow and long, most i see are wide and short. Of course I can't tell over a computer screen but it doesn't look particularly strong it looks like it's more for low tension long travel applications.
 

·
Addicted to Junk
85 Bronco, 309ci I6 w/4bbl, np435, 4" lift, 37" Irok NDs, 4.56 w/ Detroit Locker and tru trac
Joined
·
11,951 Posts
From those pics, the green thing is what I was talking about. It looks as if it could be catching on the spring. Mine was. It doesnt look straight in the pics. And if the CC isnt hooked up, undo the ball chain from your linkage to delete that as a variable.
 

·
Premium Member
Joined
·
1,727 Posts
I agree the portion between the cable bracket and where it connects to the linkage needs to be a straight shot, it could be binding. Also, it's hard to tell for sure, but the cable looks to be pulled taut before it attaches to the bracket like it's too short. I prefer a more sweeping curve in the cable, so it's possible a longer one would help. It's not hard to take off, so I would do as suggested before and take it off and see if lubing it would help, or just buy a longer one and install it. Just for reference, I bought this one.
 

·
Registered
82 XLT Lariat 351w, Edelbrock 1406 4bbl ,C6 auto, auto locking hubs ,33x10.5x15
Joined
·
2,163 Posts
Discussion Starter #27
I agree the portion between the cable bracket and where it connects to the linkage needs to be a straight shot, it could be binding. Also, it's hard to tell for sure, but the cable looks to be pulled taut before it attaches to the bracket like it's too short. I prefer a more sweeping curve in the cable, so it's possible a longer one would help. It's not hard to take off, so I would do as suggested before and take it off and see if lubing it would help, or just buy a longer one and install it. Just for reference, I bought this one.
Amazon has the ATP Y609 but says it won't fit my 82... Do u think that's right or is there a difference between the 81&82?
 

·
Premium Member
Joined
·
1,727 Posts
Amazon has the ATP Y609 but says it won't fit my 82... Do u think that's right or is there a difference between the 81&82?
I'm sure it would say it won't fit an 81 also because it's made for later models, but it's just a few inches longer.

There's no way my stock cable would work when I went with the 4V, it was plainly too short. I'm thinking yours was able to be hooked up, but is too taut and binding, so this longer one will allow for more sweeping bends. <shrug>
 

·
Premium Member
Joined
·
1,727 Posts
Just happened to think @BroncMom, that cable does not have the fitting on the end to attach your cruise control to since it is made for fuel injection. Just mentioning in case you were planning on getting that working again. I'm pretty sure the cruise could be connected to another spot on the throttle linkage though.
 

·
Registered
82 XLT Lariat 351w, Edelbrock 1406 4bbl ,C6 auto, auto locking hubs ,33x10.5x15
Joined
·
2,163 Posts
Discussion Starter #30
Just happened to think @BroncMom, that cable does not have the fitting on the end to attach your cruise control to since it is made for fuel injection. Just mentioning in case you were planning on getting that working again. I'm pretty sure the cruise could be connected to another spot on the throttle linkage though.
Dang it ? I do want to get the cruise working again... And the search continues... Unless u think that end can be removed and placed on a new cable...
 

·
Registered
82 XLT Lariat 351w, Edelbrock 1406 4bbl ,C6 auto, auto locking hubs ,33x10.5x15
Joined
·
2,163 Posts
Discussion Starter #32
Yeah not doing that ?
 
21 - 32 of 32 Posts
Top