Bronco Forum - Full Size Ford Bronco Forum banner
1 - 20 of 32 Posts

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #1 ·
flashing check engine light

ok guys got a call from my dad the other day sayin the 95 F150 4x4 i built him has a "Flashing Check Engine Light" but is still runnin like a beast,

so i go over and yep the whole time runin driving or not the check engine light comes on for a couple minutes then goes off then comes on and so on....

the truck has nothing wrong with it I put a new 302 HO in with a rebuilt trans and rebuilt 1356 elct shift transfer case, and it runs better then any truck we`ve had

but this flashing check engine light is a real eye sore and worrys me a bit
im gonna try to pull codes in the mornin:banghead
 

·
Satyr of the Midwest
Joined
·
17,738 Posts
Take this, young padawan:

 

·
Premium Member
Joined
·
23,551 Posts
has it flashed ever sense the new engine was put in?
 

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #6 ·
ok guys went and pulled codes first thing in the mornin and got these, my haynes didnt have but 1 or 2 of the codes so if someone can help translate these code for me, or point me in the right direction on fixing this, the truck still runs good accept its kinda rough at idle like its got a slight missfire,

KOEO:
111 = system pass
1 = start continuous codes(i think b/c it was separated by 6 sec pauses)
172 = hego shows lean
332 = insuficiant egr flow

KOER:
4 = 8 cylinder id#
1 = full throttle test
311 = thermactor air unresponsive
332 = insuficiant egr flow
225 = knocked not detected during response test

if yall can help thatd be great, and as for last night if you check the time, i wasnt at my dads and couldnt pull codes at that time
 

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #8 ·
thanks to jopes for the codes now i have to find out whats cuaseing them any ideas, i timed it by ear and adjusted between test drives so maybe i need to retime it with my light? and whats up with the egr insuficiant flow? and my thermactor air system bothers me a bit too:banghead:banghead:whiteflag

could timing cause all this??
 

·
Premium Member
Joined
·
23,551 Posts
when you timed it, did you have the spout connector pulled out?

chances are your EGR is just plugged up, you can remove it and clean it up.

As for the air system, check all the vacuum lines and see if one has broken off.
 

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #10 ·
well when i put the new motor in i timed it with the spout out then put the spout in and test drove it and so on till it felt just right, as for the vacuum lines i took the old crumbled vacuum lines in to the ford dealership and had them get me all brand new so there ok and only like a month old, im wondering if the timing could cause all this or not, ill take that egr off and see if its plugged, i also found that i didnt push the brake when i was supposed to or push the overdrive botton so i got codes for those too
 

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #11 ·
so goin out to take the EGR and crossover off, check for plugs, and check the EGR, TAB/TADs, and diverter valves to see if there holding and releaseing vacuum properly,

back later with updates
 

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #12 ·
ok went out and found that the tube goin from the lower intake to the EGR was broke in half and just sittin there, i pulled one off the parts truck and went to work removin the upper intake to get to the tube on the lower, got it done and fired it up, same thing check engine light still comes on??????

do i have to clear codes? how do i clear the codes?

is there another prob?
 

·
Registered
Joined
·
3,816 Posts
ok went out and found that the tube goin from the lower intake to the EGR was broke in half and just sittin there, i pulled one off the parts truck and went to work removin the upper intake to get to the tube on the lower, got it done and fired it up, same thing check engine light still comes on??????

do i have to clear codes? how do i clear the codes?

is there another prob?

Clear codes by unhooking the battery for ten minutes.
 

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #14 ·
thanks ill do that, i also herd somethin about touchin the cables together when you take em off, somethin about the reserve power for the memory
 

·
Registered
Joined
·
24 Posts
NO! Never, ever, ever connect those two cables. There's still the possibility that there's a residual charge somewhere, and if it makes it back to the ECU, it can **** it up. Just unhook the battery cablles for 10 minutes or so, and hook them back up.
 

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #16 ·
ok well cleared codes this mornin, ran the truck and pulled codes again, so now im down to three codes as follows:

KOEO
332 = insuficiant egr flow

KOER
311 = thermactor air unresponsive
225 = knock not detected during response test

ive taken the egr off and visually checked for plugs, ive check all vacuum lines for leaks and all is good there,

im startin to wonder if these last couple codes could be from havin it not timed correctly, so i went out and tried to time it but the timing mark isnt flashing at the top like its supposed to, its flashin the mark on the bottom of the balancer.....whats the deal with that should it even run like that????? its ballsy as hell and id hate to lose all that power if i retime it to 10*BTDC
 

·
Premium Member
Joined
·
23,551 Posts
I beleive EGR will not have flow with the engine off.

the thermactor air unresponsive at running means it is either not receiveing vacuum or there is a sensor / wiring problem.

the knock sensor, if yours had one is either bad, or a wiring issue


As for the timing. pull the #1 plug bring it up on compression stroke and see where the timing marks are. Balancers spin so you can never know, if spun I recommend replacing it with a new one.
 

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #18 ·
thanks jopes your help is greatly appreciated, im gonna go out and see if i cant figure somethin out, maybe poke around with the volt meter, check the vacuum reserve canister, etc etc
 

·
my bko ate my money
Joined
·
2,319 Posts
Discussion Starter · #19 ·
well got to dig up an old thread

over the past week or so ive got rid of some issues but not all im still chasing 3 codes and am becoming rather angry

the KOEO is 111 pass so all good there
continous codes are 111 pass so all good there now too

but my KOER tests are still coming up with

311--thermacter air inoperative
225--knock not detected during response test
116--ECT out of limits during KOEO or KOER tests

:banghead:banghead:banghead:banghead:cry:whiteflag

this is all on a 95 F150 2wd 5.0 MAF auto
 
1 - 20 of 32 Posts
Top