Bronco Forum - Full Size Ford Bronco Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
Gents,

Have been :banghead for the past month on this EGR valve situation. Replaced all of the vacuum lines on the truck and now the EVR solenoid is showing bad during KOEO. I am unable to find the solenoid on-line. Is this a stealership only item?? If someone has a source, please let me know.

Thanks,

NineT3
 

·
Banned
Joined
·
20,257 Posts
Have you called or gone by ANY parts stores? Have you tested your EVR with a meter, a battery, & a vacuum gauge? Have you tested the truck's wiring? Have you tested your new vac. lines? Have you tested the EGR/EVP?
 

·
Registered
Joined
·
21 Posts
Nine T3
What code were you getting from the KOEO?
I am trying to track down my EGR problem and am
now getting code 33, I think because of a bad EVR solenoid.
Thanks
 

·
Registered
Joined
·
74 Posts
Discussion Starter #4
KOEO Codes

Bronco#3,

I am getting 558 - EVR solenoid and 332 - EGR flow insufficient. They sort of follow one another, if the solenoid fails, the EGR valve will not open and the flow will be below specifications.

Later,

NineT3
 

·
Banned
Joined
·
20,257 Posts
There is no "flow sensor" on a '93. Flow is inferred from the EVP. On your truck, that code really means "EVP did not detect EGR opening".

Later engines have a PFE, & even later ones have a DPFE, which actually measures flow.
 

·
Registered
Joined
·
21 Posts
Thanks all,
Cleaned my EVR solenoid and checked its operation---all ok.
The cause of my problem was one on the nuts holding the EVP to
the top of the EGR valve was missing causing a vacuum leak.
New nut--goodbye code.
 
1 - 8 of 8 Posts
Top