Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,785 Posts
Discussion Starter #1
I just got back from Pick a Part, and pulled an EGR Valve from an 87 F-250, with a 302 motor. The 1st numbers listed along the white electrical plug ( electrical part bolted to the top of the valve) is E-3TE. The 1st numbers listed on the one I pulled off of my Bronco are ET7E. I think I remember while at the Junkyard, I saw that the ET7E's were on 351 Motors, Am I correct? The P.O fully mickey moused my Bronco. The Numbers are also listed on a sticker on the back side of the valve, which faces the upper intake. I am just curious if there is anyway to determine the numbers aside from calling the dealer.
 

·
Registered
Joined
·
2,785 Posts
Discussion Starter #2
Nevermind, I found it. By the looks of it, I got a newer EGR Valve, that someone had already replaced on that 5.0 motor I pulled it from:rockon. Hopefully it fixes my Bronco :shrug
http://www.rockauto.com/catalog/raframecatalog.php



P.S. Edited. It threw a CEL within 2 minutes. My original one does not throw a CEL at all, it just came up as malfunctioning on a scan tool test. I guess I'll just keep the original one on, until it throws a CEL.
 

·
Satyr of the Midwest
Joined
·
17,734 Posts
Try testing your EVP.
 

·
Registered
Joined
·
2,785 Posts
Discussion Starter #4
O.K. Thanks SigEPBLUE. :thumbup
 

·
Registered
Joined
·
2,785 Posts
Discussion Starter #6
So, did you just use axle grease?
 
1 - 6 of 6 Posts
Top