Bronco Forum - Full Size Ford Bronco Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hi i have a 90 eddie bauer ed bronco and my rear antilock brake light goes on but then this is what happends when it goes on i have no windows or windshield wipers or even sometimes my radio wont even work some times when i play with my key i can get my windows down but that only works sometimes does any body have any answers ive already changed all my fuses checked for shorts any help will greatly be appreated thank you
 

·
Registered
Joined
·
1,474 Posts
that is very odd, sense the ABS, radio, and windows are all on different fuses. I had a problem with the rear ABS in my 90 Bronco and it turned out to be the sensor in the rear axle, I replaced it and the light stopped coming on and everything went back to normal. Does the check engine light come on when all this happens? Sounds like there could be some messed up wiring in your fuse panel.
 

·
Registered
Joined
·
1,589 Posts
I would suspect that there is an electrical issue as you already know that but not with the ABS sensor. What ever is causing the problem just happens to be turning on the ABS light.

I saw a load tester about a week or so ago and it plugs into your current fuse location and can measure the current load. It may or may not help but you would need to know what a good load number is and I have no clue.

I would start by pulling the fuse to the power windows and see if the ABS light comes on again. If it does then the power windows are not at fault. Do you have a tilt column?
 

·
Wrenching for a Livin'
Joined
·
6,949 Posts
Steve83 said:
GROUNDSSSSSS...
i gotta agree. bad grounds cause some wierd chit to happen
 
1 - 4 of 4 Posts
Top