Bronco Forum - Full Size Ford Bronco Forum banner
1 - 13 of 13 Posts

·
Crusher Mike
Joined
·
6,111 Posts
Discussion Starter · #1 ·
OK guys I posted something in tech forums but IM too lazy to go back to it.

Ive got an 89 5.0 bronc that is giving me problems I picked it up in oregon and it ran great till I got just outside of LA ca. It started to studder and acted like it was outta gas (which it was not) after sitting on the side of the road pulling relays and cleaning connections it fired up. It got us all the way to phoenix with no problems. Then the next day we were driving it after about an hour it did the same thing then died. this time we replaced the Fuel pump Relay and the EEC relay. then it fired up but barely ran. what could be the problem. ?

Just to let you know this is what Ive replaced.

HP Fuel pump
Cap, rotor, Plugs, Wires, Coil.
Fuel filter( the crap that came outta the was grey.)
Gas Cap
Fuel regulator
Air Filter
I have not pulled any codes (no scan tool)

The truck has 52K on it but has been sitting for about 10 years
What else should I check

when it cuts out it sounds like a carb backfire but its EFI.
 

·
aka: kemicalburns
Joined
·
7,957 Posts
could be the TFI module mounted on the distributor. if they get hot they tend to fail or can fail. but pulling codes should be done for sure
 

·
Crusher Mike
Joined
·
6,111 Posts
Discussion Starter · #6 ·
kemicalburns said:
could be the TFI module mounted on the distributor. if they get hot they tend to fail or can fail. but pulling codes should be done for sure
I thought of this as well Ill pull some codes. If I have to Ill pull the TFI off it and put it on my bronco and see what happens.
 

·
Crusher Mike
Joined
·
6,111 Posts
Discussion Starter · #10 ·
351cleveland said:
the gas tank have some rust in it...if it's been sitting for a long tim...?

does it do it when you are at or near the lower level in the tank...?

just a thought.....
Yeah its at a 1/4 but weave run it empty and the fuel is now the correct color .
 

·
aka: kemicalburns
Joined
·
7,957 Posts
codes wont tell ya a problem with the tfi . but i hear ya on throwing parts at the thing. but then again youve already gone down that path by not pulling codes to begin with haha
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top