Bronco Forum - Full Size Ford Bronco Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
531 Posts
Discussion Starter #1
Now i think its the Carb but you guys tell me,

First it always takes a minute to start up and i keep it at about 15000 to 20000 RPM for about a minute before i go anywhere. When i come to a full stop and just give it a little gas, it dies! (its fine if i just about floor it) so what is it and what can i do? thanks guys
 

·
Satyr of the Midwest
Joined
·
17,736 Posts
quicksilver3602003 said:
...and i keep it at about 15000 to 20000 RPM for about a minute before i go anywhere....
:shocked :shocked :shocked :shocked



j/k, I think you meant to say, "1500-2000 RPM," but it's late and I've had a few, so I'm of good humor. I'd start by checking your float level, fuel filter, and pump. Make sure those are in proper working order.

Next, why are YOU having to hold the engine speed up so high? Is your choke not working? Fix that first!

Then you should look at the real source of the problem: the accelerator pump is probably shot. I asked that you check the other stuff first to rule out the non-obvious.

BTW, what year and engine is this on? I'm just taking a general 'stab in the dark' here. :toothless
 

·
Ex Navy Nuke
Joined
·
5,421 Posts
Sounds like carb needs adjusted or rebuilt. Or like stated above maybe it's just a sticking choke. Then again it could be in need of a full tune up.
 

·
Registered
Joined
·
531 Posts
Discussion Starter #4
Alright sweet, thanks guys
 

·
Registered
Joined
·
445 Posts
:stupid
 
1 - 5 of 5 Posts
Top