Bronco Forum - Full Size Ford Bronco Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 92 Eddie bauer. It has around 16000 original miles. This Truck hasn't been driven in a few years it has been stored in a garage. I took it out on monday and drove ti to wrok all week long and it ran like a champ. But today on my way to work I switched on the 4 wheel drive, the truck wouldn't go over 30 and the rpms wouldn't go higher than 2000. So I pulled into a parking lot took it out of 4 wheel and reversed. I still had the same problem except it took forever to reach 30mph. Than when I parked it I reved the engine and it started to boog out (while in park) at around 1500 to 2000rpms.

Any Ideas what it may be - spark plug, wire, sensor, distributer?
 

·
Registered
Joined
·
1,073 Posts
I have a 92 Eddie bauer. It has around 16000 original miles. This Truck hasn't been driven in a few years it has been stored in a garage. I just took it out the begining of the week and it ran like a champ. But today on my way to work I switched on the 4 wheel drive, the truck wouldn't go over 30 and the rpms wouldn't go higher than 2000. So I pulled into a parking lot took it out of 4 wheel and reversed. I still had the same problem except it took forever to reach 30mph. Than when I parked it I reved the engine and it started to boog out (while in park) at around 1500 to 2000rpms.

Any Ideas what it may be - spark plug, wire, sensor, distributer?
Do a tune up and put some fresh gas in it.
 

·
Registered
Joined
·
50 Posts
Besides the usual suspects (ignition and fuel) I would also check for a clogged exhaust.
regards
rikard
 
1 - 4 of 4 Posts
Top