Bronco Forum - Full Size Ford Bronco Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter #1
when i run my bronco (1995 315w) it revs it self from 500 rpm to 1000-1500 just sitting there. I have no idea what this means or why its happening. I think its a sensor but im on to good on the electical junk. also then check engine light goes on and off and this is why i think it does that but not sure what is causing it to rev up.

also..

ABS light is on...? i just redid the rear breaks does anyone have any clue to why its on?

thanks,
Kevin
 

·
Master Bater
Joined
·
7,277 Posts
sounds like several issues.
The surging could be from a vacuum leak. Check on top of th emotor towards the firewall. There are like 4 or 5 fittings right there that could come off and cause that.
The abs thing could be from any number of things that you may have changed/screwed up when you did the brake job. Pull the codes and see what you get.
 

·
Registered
Joined
·
315 Posts
check out your IAB (IAC) on the throttle body, mine had idle issues and they went away completely when i replaced that
do a search on the IAB if you want more info
 

·
Registered
Joined
·
139 Posts
Discussion Starter #4
thanks, but i dont have the computer to beable to retrive the codes
 

·
Registered
Joined
·
139 Posts
Discussion Starter #6
i dont realy get it i dont understand...? is it already in the car? and i take it out to check stuff? or do i plug somthin into it to get codes and then check them wiht a list of codes and what the mean? and the IAB(IAC) is the problem going to clean it out tommrow. thanks now all i need is to get the abs light off
 

·
Registered
Joined
·
621 Posts
the reving issue sounds like one that i had. does it do this in idle, after the engine is worm, or after initial start up? dudes on the board told me it could be my air bypass valve and sure enough i popped that baby off cleaned the plunger and havent had a problem sense. cheer's to those fellas :beer
 

·
Registered
Joined
·
139 Posts
Discussion Starter #10
yeah i gota do the same thing tommrow im sure thats the problem cuase i unpluged it and it ran wiht out reving up at all so just going to clean em tommrow and hopefuly ill be fine
 

·
Registered
Joined
·
167 Posts
simple
Throttle postion sensor
it will allow idle to go up and down, do its own thing . Cheap likeonly 30$ :beer
 

·
Registered
Joined
·
355 Posts
Volcom said:
i dont realy get it i dont understand...? is it already in the car? and i take it out to check stuff? or do i plug somthin into it to get codes and then check them wiht a list of codes and what the mean? and the IAB(IAC) is the problem going to clean it out tommrow. thanks now all i need is to get the abs light off

After reading Ryan's info, check this out...
http://www.dalidesign.com/hbook/eectest.html

Then, if you can not figure it out, find a freind who can, or find a decent shop who'll do it for you.


Bob K.
 

·
Registered
Joined
·
315 Posts
the IAB is the Idle Air Bypass (valve) it has a lot to do with the warm up cycle and any other times your engine needs a little more umph, like when you turn on your A/C or something, it sounds like your engine is just confused about when to give that extra rpms so it revs randomly, cleaning the IAB is a good start but make sure you do it with the correct cleaner (sensor freindly) or you will have to replace it anyway (like me) but it fixed my problem,

Getting codes: your truck has a computer in it, it runs your efi system, there is a plug (shown on ryan's site) that you can insert a test light into and when you follow ryan's instructions your trucks computer will "read out" through a sepecific series of blinks in the test light, any problems it sees with your engine
 

·
Registered
Joined
·
139 Posts
Discussion Starter #14
ok i replaced the iac today and it seems to be worse it idles up high and stays there. There is no vacum leak. Any clue to what could be wrong?
 

·
Charlie don't surf..
'92 Ford Bronco XLT
Joined
·
15,075 Posts
Did you disconnect the battery to reset the computer,. You need to do this for at least 15 minutes, so the computer can adjust to the new sensor you just installed.
 

·
The Anti Yam!
Joined
·
22,680 Posts
Volcom said:
i dont realy get it i dont understand...? is it already in the car? and i take it out to check stuff? or do i plug somthin into it to get codes and then check them wiht a list of codes and what the mean? and the IAB(IAC) is the problem going to clean it out tommrow. thanks now all i need is to get the abs light off
Read this it has pictures and it's very easy.

http://fordfuelinjection.com/selftest.html

If you cant figure that out then you need to take it to a shop.

You are wasting your hard earned mony throwing parts at it when the computer will probably tell you what is wrong.

Good luck :thumbup
 

·
Registered
Joined
·
643 Posts
tps. changed mine and went away fer awhile now it came bak slightly and i jus ignore until it gets as bad as it was thenn ill ge off my ass
 
1 - 18 of 18 Posts
Top