Bronco Forum - Full Size Ford Bronco Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Hi Guys.......OK, here's one for you wiring experts. I'm re-installing a factory radio in my '91 Bronco that was removed by the previous owner. I replaced/repaired the OEM wiring harnessand plugs that had been cut (original plugs removed). I then found several OEM radios I could use.......... but here's the problem.

One of the radios I'd prefer to use is originally out of a '91 Ford Aerostar Van, which appears to be nearly exact to the Bronco radio. The reason I want to use the Aerostar radio is because it is much easier to find an Aerostar radio as oppossed to a Bronco radio. They are much more plentiful and have all the same features (clock, etc.). When I hook up the radio, the passenger side speakers do not work.......at all. However, if I hook up a OEM radio out of a same year Crown Victoria (also very similar radio but with out the clock), everything works fine. I tried a different Aerostar radio but with the same results. Passenger side speakers do not work. So, I'm assuming either I have two bad Aerostar radios, or there is some weird wiring thing going on.

Does anyone have any ideas?

Thanks........

Stuart
Portland, Oregon
 

·
Registered
Joined
·
2,437 Posts
I'm guessing the wiring sequence in the harness is different amongst the different radios you are trying to use. You will need to get the correct harness for the radio you want to use and wire that into your BKO's wiring using the proper wiring diagram for your truck. G/L
 
1 - 2 of 2 Posts
Top