Bronco Forum - Full Size Ford Bronco Forum banner

1 - 15 of 15 Posts

·
Banned
Joined
·
470 Posts
Discussion Starter #1
My Blinkers(turnsignals) blink way to fast. They blink about 4 or 5 times faster than my hazards. I don't think a bulb is out anywhere, but am not 100% sure. I tried replacing the blinker unit in the fuse panel and that wasn't the problem. Today my right blinker went out for a while but came back.
 

·
Registered
Joined
·
297 Posts
You have a short/ground issue. Check all the bulbs and make sure they are all tight in the socket and working. Does it make a difference from left to right? If so check that side first.
 

·
Banned
Joined
·
470 Posts
Discussion Starter #4
94bronco said:
You have a short/ground issue. Check all the bulbs and make sure they are all tight in the socket and working. Does it make a difference from left to right? If so check that side first.
Same on both sides!
 

·
Registered
Joined
·
297 Posts
I know you replaced the blinker fuse thingy, can't remember the correct term, silver thingy on the fuse pannel. Did you get the heavy duty trailer kind or stock?
 

·
Banned
Joined
·
470 Posts
Discussion Starter #6
94bronco said:
I know you replaced the blinker fuse thingy, can't remember the correct term, silver thingy on the fuse pannel. Did you get the heavy duty trailer kind or stock?
The package just said "Heavy duty flashers for car and truck applications"
It's for 2-6 bulbs,but I took it out and put the original one in because there was no difference between the two. It worked the same with both.
 

·
user title
Joined
·
2,211 Posts
I have the same problem...blink fast on both sides when I want to turn...I am looking forward to an answer. Mine have never gone out, they just blink fast.

:beer
Bill
 

·
Banned
Joined
·
470 Posts
Discussion Starter #8
I have the same problem...blink fast on both sides when I want to turn...I am looking forward to an answer. Mine have never gone out, they just blink fast.

:beer
Bill
Do your hazards blink normally? mine do
 

·
Registered
Joined
·
17 Posts
I had the same problem on an old jeep. I had to start tracing wires and finally found the problem. Corrosion! :banghead One of the ground wires that connected to the frame was corroded at the connection. Good luck. If anything it is a good excuse to get out of the house and into the garage.
 

·
user title
Joined
·
2,211 Posts
Yeah...hazards blink normally....

And...where can I find that blinker fluid reservoir? Is that right next to the stickers that had 15hp?

:beer
Bill
 

·
Banned
Joined
·
470 Posts
Discussion Starter #12
juggernaut89 said:
cant resist this one... :thumbup
Check your blinker fluid reservoir :rockon
:wacko :stupid
 

·
Registered
Joined
·
313 Posts
Okay, I'm reviving what seems to be a dead post here. Except....it's different! (sort of.) So, my blinkers blink really fast too. But, my hazards blink normally. The weird thing is, that all my blinker lights work, but when I click on my hazards, only 2 of the lights on the outside of the truck blink (can't remember which ones), but the dashboard shows them all working. Now, I'm far too lazy to look for shorts in those flippin' wires, so...any easy fix here? It bothers that if i ever needed my hazards that they wouldn't work...and that my blinkers are insanely fast. Any hints here?
 

·
Registered
Joined
·
1,117 Posts
The wiring diagram says that the turn signal and the hazard flashers are both on the fuse panel.IIRC one flasher is on the front of the fuse panel and the other is on the back of the fuse panel,directly behind the front one.Pull the front flasher out and try both the turn signals and the hazard flashers to see which one dosen't work,then you will know if you changed the right one for the turn signals.
 
1 - 15 of 15 Posts
Top