Bronco Forum - Full Size Ford Bronco Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·

·
Charlie don't surf..
'92 Ford Bronco XLT
Joined
·
16,204 Posts
That set up looks good Wes, so the 60 is working well for you?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #3 ·
yeah I haven't had a chance to really test it because I couldn't steer it, but I took it out behind my house and ran through my little test course, and it worked well
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #5 ·
yeah it was pretty bad...it could be because my pwr steering pump needs to be replaced but I'm holding out for my 460 swap, so I can use a saginaw style pump
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #6 ·
anybody have a line on a 460....carb or EFI doesn't matter
 

·
tired of your sh!t
Joined
·
2,880 Posts
other than the worn out parts, the first pic looks like it would handle better in regards to bumpsteer(trackbar &draglink)). do you have any bumpsteer now? and what are you doing with the trackbar?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #8 ·
no bump steer would be worse with the first picture...if you will look at my draglink with my new setup it's perfectly parallel with my trackbar which completly eliminated my bumpsteer. I'm not sure what you are asking with your last question ( what are you doing with your draglink?) my old draglink was too short when I swapped to the 60, and is currently in my junk pile. If you are asking about where I located my new trackbar, I used a high steer arm on the passenger side
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #9 ·
1 - 9 of 9 Posts
Top