Bronco Forum - Full Size Ford Bronco Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
2,330 Posts
Discussion Starter #1
When you first brought your Bronco Home what's the first thing that broke on it?

In my case it was a Ragjoint, between him using a towbar to push my bronco into the garage and the tires was turn the wrong way, I started turning the tires the right way and POP goes the joint! LOL

So after I determine if the motor is any good I will start replacing stuff and one thing on the list already is the rag joint. lol
 

·
Driving Stuff Henry Built
-90 xlt, 351w, e4od, man 1356, 3.55, sag, warn hubs, 35s. -73, 400, np435, d20j twin, 35s
Joined
·
8,183 Posts
Alternator (Not needed) & ground cable (Actual problem). Here's the story from my intro right after joining FSB.
I found one on eBay up in Utah. My wife & I drove all night to meet the guy at DMV Saturday morning for temp tags to get it home (Cal+Utah =Stupid DMV rules). On the way home it quit charging. We had changed the alternator in my son's shortly before and in my sleep deprived state I swapped this one without really testing it (No sleep is bad for diagnostic skills). It had better voltage with the new alt, but as we traveled, it was on again off again. We decided to continue on, jump charge it from the other car when needed, and figure it out when we got home. Turns out it had a bad ground from engine to frame to battery. We stopped for gas in Victorville CA, tried to start it, and smoke poured out from under the hood.
I thought I had set my new Bronco on fire. The little ground wire from the battery to the radiator support tried to carry the load for the starter. A lot of smoke for one little wire. It's easy to find the trouble when it smokes & glows red. We cooled it, taped it and charged the battery again. We drove it the rest of the way without turning it off. Once home the first repair was the new ground.
 

·
Registered
Joined
·
9,894 Posts
Drivers side radius arm.. (Well it was broken when we bought it and limped it home like that)..
 

·
Premium Member
Joined
·
919 Posts
rear brake shoes delaminiated, the rad rad sprung a leak. other then that been good since
 

·
Premium Member
Joined
·
144 Posts
Not really something that broke, but I just got two flat tire on my way to the beach this last 4th of July weekend. It was a 3 hour drive and I had to limp home on two stock size tires and two 33's. Those tires are the first thing that I had to replace since I got the Bronco in February.
 

·
Satyr of the Midwest
Joined
·
17,734 Posts
Girlfriend's knee. No, really.
 

·
Mud God - R.I.P.
Joined
·
5,788 Posts
66= Fuel pump
B+W 79= carb "did not have one"
Green 79= Only a body so far:haha
87=burnt valve
 

·
Premium Member
Joined
·
4,780 Posts
Well, technically, I got the Bronco from my FIL by replacing the frozen water pump. But, after I got it home, a few weeks later, the gears for the back window went out and I had to replace them. Other than the A/C vacuum line and just recently replacing the Negative cable, everything else is in pretty great shape for an 18 year old truck. I think I may be getting the B pillar cracking but not 100% certain if it's not just the paint cracking
 

·
Kitteh Commandaar!
Joined
·
4,191 Posts
Motor, but it didn't have one in when I bought it...:toothless

KC
 

·
Registered
Joined
·
496 Posts
bought mine with the passenger window gear bushings blown up. but since then i've replaced the tailgate motor gear, bushings in the front window motors (both). replaced the rubber on the windows, belt tensioner, idler pulley, power steering pump, upper rad hose, and bought a big alternator, but haven't wired it up and hooked it up yet. oh and a tune up to get better mileage.
some of that stuff wasn't exactly broken, but i replaced it before it went
 

·
Seeking Tanelorn
Joined
·
21,173 Posts
Tranny and radiator. Not sure which went first.
 
1 - 20 of 32 Posts
Top