Bronco Forum - Full Size Ford Bronco Forum banner
1 - 3 of 3 Posts

·
Registered
1990 EB, 5.0
Joined
·
440 Posts
Discussion Starter · #1 ·
Guys, I've got a flickering battery light in my 1989 5.0. Can't find a thread that addresses this on the forum. Checked it with the voltmeter, and I've got 12.6 volts from the battery static and over 14 volts when running. Been searching down connections and checking wire security to no avail. The flicker isn't a problem, just annoying. Thinking it might be a lightbulb in the dash, but before I go through that level of pain thought I'd ask here.
 

·
Super Moderator
Joined
·
29,107 Posts
Yo Siggy,
Inspect parking brake switch at top center of the parking brake for loose wiring connectoror or switch looseness.
The switch contacts are exposed and can be cleaned. The dash light comes on key is turned to run.

170016


Ground G801 serves driver side park/turn lights, ws washer pump, driver side headlight, etc.
Or loose cluster bulb or corrosion.

Have to think about more possibilities.
170020
 
  • Like
Reactions: Siggy89

·
Registered
1990 EB, 5.0
Joined
·
440 Posts
Discussion Starter · #3 ·
Yo Siggy,
Inspect parking brake switch at top center of the parking brake for loose wiring connectoror or switch looseness.
The switch contacts are exposed and can be cleaned. The dash light comes on key is turned to run.

View attachment 170016

Ground G801 serves driver side park/turn lights, ws washer pump, driver side headlight, etc.
Or loose cluster bulb or corrosion.

Have to think about more possibilities.
View attachment 170020
Thanks man I’ll check that out and let you know
 
  • Like
Reactions: miesk5
1 - 3 of 3 Posts
Top