Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
202 Posts
Discussion Starter #1
Hey everyone,

Been doing some searching and i'm finding all kinds of information. Unfortunately it has given me even more options as to what is wrong with my truck. So i was hoping perhaps some of you could direct me towards which part(s) i should start replacing first.

My bronco information is to the left. The problem i am having is

The truck starts fine, idles fine, doesn't smoke, but it hesitates upon first getting into the gas pedal but will then open up and take off. The truck does run warmer than it should because the thermostat and radiator need to be replaced, but i keep an eye on it in the meantime until i can afford to buy those parts. now when taking off, sometimes it will take off fine, sometimes it moves like it's in third gear. Also, in gears 2-4 as soon as it shifts the tranny has torque to pull but after about 5 seconds it just falls, like it is in nuetral, but will then pick back up and start picking up speed again. It also shudders everynow and again when going down the road as well. also going up hills makes it seem to not want to pull its own weight. i have pulled codes it gives me one for the vss and two for running lean, bank 1 & 2. i have replaced the vss and the neutral safety switch. my CEL is on, so is my abs and airbag light. Also, my overhead console blinks or flashes per say, like it has a short. sometimes it will come on and appear to work properly but most of the time it sits up there blinking. don't know if that has anything to do with anything.

so where should i start folks? Any help or information on any of my problems would be greatly appreciated.

ps-if it counts, i have no smog pump or cats.
 

·
#1 Asshole
Joined
·
1,452 Posts
Shuttering is the torque converter clutch. Running lean do a fuel pressure test mine was doing about the same thing before I changed the fuel pump. I was only getting 28psi wot or idle and 32 psi idle with fpr unhooked now I have 33 idle and 43 wot runs a ton better.
 

·
Registered
Joined
·
7 Posts
Sounds similar to mine, mine had no codes, 90 eddie bauer, same things but would actually die when you say yours shutters. Ended up being the ignition module, tune and that have it running great. Not that I know enough to comment but sounded similar.
 

·
Registered
Joined
·
202 Posts
Discussion Starter #4
Shuttering is the torque converter clutch. Running lean do a fuel pressure test mine was doing about the same thing before I changed the fuel pump. I was only getting 28psi wot or idle and 32 psi idle with fpr unhooked now I have 33 idle and 43 wot runs a ton better.
Lack of fuel pressure wouldn't cause the shutter? or perhaps a bad regulator? the last thing i want to hear is major tranny issues. I was hoping for a sensor a valve a selenoid, anything not so major. Can the clutches be easily replaced? or is that a whole new TC or how's that work? :tinfoil
 

·
Registered
Joined
·
202 Posts
Discussion Starter #5
or how about a TPS? would that cause a shutter? i can step on the gas pedal in idle and the tach just doesn't respond very fast. Just a thought.
 

·
Registered
Joined
·
9,895 Posts
There's is a write up on the place to test the TPS.. Bascially Key on engine off.. Stick a volt meter into the back side of the plug and move the throttle.. You should get a good smooth sweep and it should go up to a max of 5 volts if I remember right..

I'm not to sure on the problem but at first guess I'd say it "might" be a torque converter issue..

I'm having a similar issue with my F250 diesel.. I've been trying every trick I know with a gas motor and it's not fixing it.. :banghead hope it's not a fuel injector.. Stupid injectors are $320 each.. :Cry
 
1 - 6 of 6 Posts
Top