Bronco Forum - Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter #1
you know the fuse for the power mirrors, dome lights, speedometer, and odometer. It's all one fuse. It's a 15 amp fuse. It keeps blowing instantly as if there is a short somewhere. I even made a little jumper wire, put it in place of the fuse, and the coating on the wire melted. Any suggestions on where I should check next? Any help would be greatly appreciated!
 

·
Ex Navy Nuke
Joined
·
5,421 Posts
Have you recently done any work near any of the parts powered off that fue? Don't try the jumper idea again, unless you want your Bronco burned to the ground. I would say to look for a cut wire going from the body to the door. That seems like a pretty likely place for a wire to get damaged. Other than that just backtrack from everthing that is powered off that fuse.
 

·
Registered
Joined
·
151 Posts
Discussion Starter #3
Haven't done any work that i can think of. Although my dome lights do not work even with the jumper wire even though this fuse is for the dome lights. Could this mean anything?
 

·
Satyr of the Midwest
Joined
·
17,736 Posts
There ya go, I think you just isolated the faulty circuit! Probably one of the +12V feed wires eventually going up to the dome light is pinched or lost its insulation somehow, and it's shorting to ground. I'd do like Bob suggests and check the door-to-body connection first. I have the feeling you're going to find a clump of melted wires eventually, so be sure to replace any wire that's not in tip-top shape.
 

·
Ex Navy Nuke
Joined
·
5,421 Posts
I didn't notice dome light in your first post. That had happened to a couple people that I know of before. Pull your dome light off and check that first, there is a hot wire up there.
 

·
Registered
Joined
·
151 Posts
Discussion Starter #6
Today I spent several hours on this. I pulled out the wiring for the middle dome light and found out that when I replaced a screw that holds the side panel on, it went through the wire and that's where the short was. Now i have another problem. I replaced the wiring, now the middle dome light comes on only. If I cross the two wires , then the rest of them come on and they all stay on even when the doors are shut. i just gave up today and am really stumped. Any advice?
 

·
Registered
Joined
·
1,864 Posts
1 - 7 of 7 Posts
Top