Bronco Forum - Full Size Ford Bronco Forum banner
1 - 4 of 4 Posts

·
Registered
1987 Bronco Eddie Bauer 5.0 with AOD
Joined
·
37 Posts
Discussion Starter · #1 ·
I've been trying to figure out why my thermostat gauge and fuel gauge hasn't been working right. I took the gauge cluster out and found that the laminated circuit board has a couple places that are burned out. Also it seems that the little square resistor board isn't allowing any voltage through. I haven't been able to find any replacement circuit boards for sale. does anyone know of any around or where to find them? It is the e7tf-10c956-A type. Am I able to use the e9tf newer style? made sure all the gauges work and have changed out the sending units. Thanks for any input or help on finding one.
 

·
Registered
82 XLT Lariat 351w, Edelbrock 1406 4bbl ,C6 auto, auto locking hubs ,33x10.5x15
Joined
·
4,077 Posts
Did you check lmc truck or Jeff's bronco graveyard?
 

·
Super Moderator
Joined
·
28,219 Posts
Yo Kasey,
When I thought my PSOM was bad, I shipped it to DNA SPEEDOMETER, Tampa, FL
DNA has Excellent service!
Read my comments as well as joej85a's + experience @ Bouncing Speedo after cluster light repair

Call them on Monday
(813) 875-8226
Read about how to pack it,etc.
 

·
Addicted to Junk
85 Bronco, 309ci I6 w/4bbl, np435, 4" lift, 37" Irok NDs, 4.56 w/ Detroit Locker and tru trac
Joined
·
15,632 Posts
I have a handful of 87-91 clusters with tachometers if you need one. I think i have an AOD one. PM me if interested
 
  • Like
Reactions: miesk5
1 - 4 of 4 Posts
Top