Bronco Forum - Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
622 Posts
Discussion Starter #1
This 94 has the 4speed automatic trans with over drive,manual shift trans case,302 and every thing I just mentioned is in excellent shape.the problem I'm having now is that after I drive about 6 to 10 miles and go to turn usually to the right,it feels like a brake is draging in the back.I had it do it a minute ago when I came home and had the wife come out and pull forward while I checked shit out from outside.If I touch all the hubs I feel it but really bad in the back wheels.Its like jumpy.I can jack it up though and the wheels spin fine, no brake hang up.Brakes are knew all the way around and I put knew hardwhere on and rebuilt the front calipers over this shit.Now the catch is it only does it when I have the wheel turned or I'm making a turn.Oh put new bearings in the rear to over this.The rear inside has what looks like a small clutch pack in it.Three tabs I believe on the disks I could see.Is it some kind of limited slip,tracktion lock or what?That is the only other thing myself I can think it could be.

Thanks in advance for any info,Steve
 

·
Registered
Joined
·
622 Posts
Discussion Starter #3
Yeap thats it!I thought it would be that but I guess part of me was hopeing it would be something cheaper and easy to change.Would that be that complicated to change the clutches in myself or does EVERYTHING have to be redone?Just put the good VAVOLINE gear oil for limited slips in it but no addative.You think: it might help or is it shot?

Thanks Steve :cry
 

·
Banned
Joined
·
18,967 Posts
If you keep the carrier shims organized, you don't have to re-set the gears. But it's hard work - if yours is tight enough to feel, your S-spring is probably too tight to remove/install without the special tools.
 

·
Registered
Joined
·
1,121 Posts
What weight gear oil did you put in?You should use an 80/90 gear oil or a 75/140 synthetic gear oil and add a bottle of Ford limited slip additive,then drive in a figure 8 pattern for 10-15 figure 8's to work the additive into the clutches.I've heard that the gear oils with the additive sometimes cause binding or chattering in the limited slip when turning.
 

·
Registered
Joined
·
622 Posts
Discussion Starter #7
It's 80/90 Valvoline.And has all that mumble jumble shit about limited slips on the back but doesnt actually say it has the addative in it.
Can I just pump out the 4 ounces and add the addative or is this FORMULATED for limited slips stuff what is causing my problem?
These Broncos really seem to be tempramental about a lot of things.I've probly owned somewhere in the range of 400 cars and trucks in 25 years with all my wheeling and dealing and this has been one of my bigger pains in the ass.67 to 69 Camaros with 10 and 12 bolt limited slips and never used the addative and never had a problem.Binding and chattering hits it on the nail head though.
Also I've been looking around trying to find clutches for this just in case.But not having much luck.Alot of whole carriers but not just a clutch pack.
 
1 - 7 of 7 Posts
Top