Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hey guys,
I hope someone here can help me out. I have a 95 XLT with almost 74,000 miles. My tranny is giving me trouble, it's slipping, sometimes it's real bad. There's times, when I'm stepping on the gas and just doesn't want to shift. But, this happens at various speeds. When this happens I pull over and shut off the truck for about a minute, start it back up and 9 out of 10 times just goes away! There's times that it drives fine, there's times it acts up, I can't figure it out :banghead
I changed the tranny fluid (drained torque converter too), new filter, and added Lucas to it. I did this about 100-200 miles ago, but it's still happening. I've also heard a mechanical noise coming from the tranny when it's slipping and trying to shift. I should mention that the engine light is on; I have not scanned it yet. Any ideas on what's happening? Thanks in advance for your help.
 

·
Registered
Joined
·
1,011 Posts
Sounds like you better save up for a tranny re-build.
 

·
Registered
Joined
·
179 Posts
Codes! The answer should be there. What did the fluid look like? Did this start before or after fluid change? good luck. hopefully it's only an mlps.
 

·
Registered
Joined
·
1,864 Posts
Yes......your best bet at this point is to pull the codes and see what your working with. You may be looking at some sort of component failure.....or it could be the E4OD getting ready to take a crap????

If you do need to replace the trans with a rebuilt unit, make sure that the place you get it from beefs it up. If you search here you will find plenty of info on exactly what should be done to the E4OD to make it bullet proof.
You could also go to Jasper (good quality rebuilds and a good warranty, or go with a place like Phoenix Manufactured Transmissions).
If it was me though.....I would have to shop around a bit......I think I would also go for a few extra bucks to buy a unit that has been built to handle everything a FSB can throw at it and more!
 

·
green ones make me horny
Joined
·
11,154 Posts
like everyone else said pull the codes and see. there could possibly be something else making the tranny slip. for example i blew a fuse that ran all the dash lights speedo etc. and it also made the tranny shift real hard. not saying thats what happening to you but it is a though
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
thanks for the replies. this was happening before i changed the tranny fluid/filter. old fluid was pretty bad. but, it still happens after changing fuild/filter + adding half bottle of Lucas. will pull codes, and keep you posted.
 
1 - 6 of 6 Posts
Top