Bronco Forum - Full Size Ford Bronco Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Hello all, My problem is this:When I turn my Headlights ON
they draw too much power,everything dims down unless I hold the gas a little
Too keep it above 1000 RPM.....I think it might be bad ground(but not sure)
Anyone know a fix?I tried the search but didn't find any info


1993 Bronco XLT 5.0 Automatic w/OD :usa
 

·
Registered
Joined
·
315 Posts
well i would start by checking the wires from your harness into the headlights, follow them as far as you can, even if you have to pull them out of the loom,
look in your haynes or chiltons wiring diagrams to see where the headlights go through any relays or grounds and check those as well,
you might also try inspecting your switch.

im not an expert but at least i replied :rolleyes:
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
:) Thanks for all the Help.......I'll try the alt.(g3) and see how that works..
 

·
scrounger extrordinaire
Joined
·
4,775 Posts
geez man how many lights do you have? i only have a 100A alt and 4 KC lights on a roof bar, but i can turn on the headlights, radio and the KCs at idle in park and nothing dims. before you convert to a 3G alt try getting yours tested at a parts store, if you can take it off and get it there. you may just need a new one and thats easier than a 3G upgrade, which isnt hard. whats your RPMs at idle? my truck idles high so i never have to worry about power at idle. good luck.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7
Mine is a 90A and Well I don't have any extra stuff.....it's all stock.....
but it works good,"except"when in drive,
I have the usuall stuff on(heater,radio,headlights,etc.)and I stop at a red light....
everything draws too much power......Unless I am above about 1000RPM then its fine....
time for a new 140A alt.(got to look around first for the best deal):cool:
Thanks for all the help,you are great;)
 
1 - 8 of 8 Posts
Top