Bronco Forum - Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
1978 Bronco, 351M
8 years ago the engine was in pretty good shape. It has been worked on a few times since then and there appears to be something missing now. specifically, it appears to be part of the throttle body. i need you to help me figure that out.
here's the engine 5 years ago.
http://farm5.static.flickr.com/4005/4683597643_38c110efd4_b.jpg
the red circle shows the piece that's now missing. here's another angle.
http://farm5.static.flickr.com/4017/4683597609_acd3c1ba6b_b.jpg

here's the engine now (fuel hose has been replaced since i took the picture).
http://www.flickr.com/photos/[email protected]/4679976415/sizes/l/
here's another view.
http://www.flickr.com/photos/[email protected]/4680609336/sizes/l/

is it a throttle position sensor? or a return control device? or both? neither?
 

·
Registered
Joined
·
710 Posts
I can't tell you what it is, but I can tell you that I highly doubt it's a throttle position sensor.

that is unless that carburetor is masquerading as a fuel injection system...

of course I could be wrong, forgive me, I'm bored...

If I had to guess what it is, I would say it is either some type of high idle critter to help with warming up the engine, or a vacuum control of some type.

either way I don't think you "need" it.
 

·
Registered
Joined
·
178 Posts
I am not sure, but if your carb has been sitting for 8 years I doubt it is good to go. Likely is going to need at least to be rebuilt or replaced.
 

·
Premium Member
Joined
·
12,534 Posts
You have a carb, not throttle body. The part that is missing is the idle stop solenoid. Parts stores carry them.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks so much Ranger. I'm on it!
The bronco has been sitting for about a year (I know...I do feel guilty), but still starts and idles just fine.
Can I bother you for one more answer? What is the function of the idle stop solenoid?
Thanks again for helping me learn!
 

·
Registered
Joined
·
2,153 Posts
My 78 came with factory ac. On mine, that part kicked the idle up, when the ac was turned on. I used mine when I did the OBA, to raise the engine speed, wheen I was pumping air. I didn't even have to rewire, just slide the climate control lever to ac, and it engaged the solenoid.
 

·
Side step it
Joined
·
1,583 Posts
If I'm not mistaken it also kicks it up when it's cold too...if you don't have a automatic choke!
 
1 - 7 of 7 Posts
Top