Bronco Forum - Full Size Ford Bronco Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1 (Edited)
HELP - Stupid mistake now I need to fix - ignition - FIXED!!!!

OK I feel really dumb on this one. My truck was running fine then the ignition actuator broke. I got the parts and started to fix it. I was finishing up the reassembly when the ignition switch arc'ed - I thought I had the positiive off but apparently it was still on like a fool.

So here is what has happened so far. I finished putting things back together and there was nothing when I flipped the truck into run - no start, no pw windows, no CD player etc. I replaced the ignition switch to be safe while it was all apart and then checked the fuseable links by the battery - found 2 that pop'ed and replaced. I checked all the others with an ohm meter and they all have 12 volts on them. Once I did that I now have everything when in run except the truck wont try and turn over. The starter motor does not even try to engauge. I replaced the starter solinoid but no dice.

What else should I check? Is there any more fuseable links or relays anywhere that could have blown?
 

·
Registered
Joined
·
2 Posts
try turning the kety to run and jumping the starter selinoid and see if it cranks, then its and easy fix, you could aslo check power to the start selinoid.

just my .02 cents
 

·
Registered
Joined
·
271 Posts
this happened to a mustang of my step dads and i got a spark will doing it also. it burnt a wire right near the starter solenoid, look there. may not be the same situation but its worth a try.
 

·
Registered
Joined
·
2,153 Posts
Actuator rod could be out of adjustment. Get under the dash, and trace where the rod actually goes to the ignition switch. Turn the key to the "run" position, then take a pair of pliers and push on the rod, towards the switch. If it then cranks, then you installed the column parts one or two notches off. Take it back apart, and try again.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #6
OK I tried jumping the solinoid and it sparks but the starter does not even try I dont think - I hear a click but I think thats coming from the top end not the starter. I tried also in neutral as FYI. I tried pushing down the rod as well the toher day as that was my first thought once I had accessories back. I was under and only saw 1 wire going to the starter - I am used to seeing 2 or 3 is it just a single power wire that goes from the starter to the solinoid?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
Also I tried taking the wire to the starter and touching it straight to the positive - no dice same single click sound but not repadtive like I would expect - this is really starting to suck.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #11
OK Got it fixed!!! OK so here is a list of what I had to do:

Replaced the actuator (what I originally started on)
Replaced the ignition switched from being shorted
Replaced the start solinoid
Replaced 2 fuseable links near the battery that shorted
Replaced the negative cable (think this was a big part the final thing that did it was the cables listed but this cable looked the worst)
Replaced the positive from battery to the solinoid

Once I did this it still did not start inside but I was able to jump the solinoid and it started

Went back to the original issue and put it all together then the key to start and pushed allt he way then added some downward to the rod and she went

Now I knew I was a couple teeth off - pulled the key lock and redid that piece

Boom now she started!!

Turned out to be a bit of everything so the ideas helped - thanks hopefully the fix here will help someone else if they break and manage to use search lol.
 
1 - 11 of 11 Posts
Top