Bronco Forum - Full Size Ford Bronco Forum banner

1 - 18 of 18 Posts

·
4:20 Enthusiast!
Joined
·
3,277 Posts
Discussion Starter #1
Hows it goin' all,its been awhile since my last post.Its good to here FSB made #1.:rockon :beer
My truck hates me!
Every time the weather turns to crap,I find myself crawling under my truck.We just received 30" of snow and my starter died (well I thought)while at my kids hockey practice.My mechanic:twotu: came by to look at that night at the arena and tried boosting my battery.My battery is fine.He tried jumping the solinoid,no luck but lotsa cool sparks!He suggested it was my starter.He drove me home .The next day my pop gave me a ride to my truck to try andboost the battery again,no luck.We then hooked A tow chain up and proceeded to tow me around the parking lot while I popped my clutch to try and start it,NO LUCK.But it sure was a blast as I was going sideways and sliding all over the place.I almost shit mt pants when I hit the only patch of exposed ashphalt siedways.Had nightmares:shocked of rolling over!Towed it home.I called NAPA and they delivered me another starter.Mine was only a year old and still had 2 years on the warranty.:twotu:
I got to install the new starter today.Its snowing like f#$%^&king crazy outside.Still no luck!:banghead I changed the solinoid.Still no luck @#%$*$%^(*^%^&*(*&%^(*&^%^&*()(^%$%^&*!:banghead :banghead :banghead





HELP!!!!
 

·
Registered
Joined
·
560 Posts
any noises? if nothing is happening it migh tbe you ignition switch.
 

·
4:20 Enthusiast!
Joined
·
3,277 Posts
Discussion Starter #3
OOOOOOOOOOOps!Sorry .My truck goes click click click click click click sounds like from the solinoid area.But I changed that too!
 

·
4:20 Enthusiast!
Joined
·
3,277 Posts
Discussion Starter #5
I still have to check those again ,Everything looks fine.LOOKS>I have checked and cleaned everything.I'm starting to wonder if its simply my battery post connectors.
Any other ideas would be greatly appreciated and thank you for the help!
 

·
Registered
Joined
·
29 Posts
I just had something like this on my 88 5.0. It turned out to need a new battery. The old one with a Ford exploder trying to jump it, wouldn't do anything. a battery charger with a starter mode wouldn't even start to turn it over. Went down and bought a new battery, new terminal leads. Looks good and turned the thing over like a porfessional hooker. Have you had your battery tested? Oh, yeah NOTES: with charger on start mode, jumping the solenoid would make sparks. Needs a lot of amps to turn that motor over. The new battery has 775 cold cranking amps.
 

·
4:20 Enthusiast!
Joined
·
3,277 Posts
Discussion Starter #7
I just tried jumping the new solinoid from 1 side to the other and the only thing that happened was the positive post sizzled the snow off.:banghead
 

·
Registered
Joined
·
9,894 Posts
Check your wires going to the starter.. Make sure they are good..

I basically said that so I could say.. Hockey rules!
<--- goalie. :)
 

·
4:20 Enthusiast!
Joined
·
3,277 Posts
Discussion Starter #9
I basically said that so I could say.. Hockey rules!
<--- goalie. :)
Cool:rockon
Yes on the wires.We are in the middle of a snow storm right now!:banghead I wish I had a sled
 

·
Registered
Joined
·
58 Posts
Not sure exactly where you tried jumping to the starter, but check the connector(s) on the wires going to the starter, esp. the solenoid. My solenoid connector was oxidized (rusted) and I'd get the same thing (click click click). The battery was good on mine too. After a wire brush cleaning and some dielectric grease, it starts fine now.
 

·
Registered
Joined
·
621 Posts
new solenoid-new starter. my truck needed a battery when that happened to me, so i broke down and bought an optima for 106 bucks. that or check ground cables first.
 

·
Registered
Joined
·
9,894 Posts
I did have an issue with our bronco doing the same thing.. I would pop the hood and twist the terminals that connect to the battery a little and it would fire up.. Since them I've replaced the termnals and it is good now.
 

·
4:20 Enthusiast!
Joined
·
3,277 Posts
Discussion Starter #13
:banghead I'm losing it!:banghead :banghead :banghead
I had my truck running.Now its dead again.I've changed the starter(new from NAPA)I've changed the ground cables.i've changed the solinoid,i've changed the battery,I've checked all connections and recleaned everything.All it does when i turn the key is click click click click:banghead :banghead :banghead :banghead :banghead :banghead :banghead :banghead :banghead :banghead :banghead :banghead :banghead :banghead :banghead :wtf
 

·
Registered
Joined
·
745 Posts
hey man i had the same EXACT problem earlier last month,
I checked the amperage on the alternator, and the battery and they are both low, so ended up relacing one thing at a time(starter, alternator, battery cables, solenoid, even added a new solenoid ontop of my new starter)
and none of that fixed my sketch starting problem.
ended up replacing the battery to a redtop last week.... NEVER started better man :)
replace the battery and see what happens, if thats not it.. then you got a new kickass battery and your only setback $115 :beer
 

·
Registered
Joined
·
5 Posts
The same thing happened to me a couple of moths ago. It turned out that the starter got a little dirty and kept getting stuck on the flywheel.
 
1 - 18 of 18 Posts
Top