Bronco Forum - Full Size Ford Bronco Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 1989 Bronco with 302. Problem is with idle at startup. It is hard to start, but when it starts, it jumps to 2000rpm for about 10 seconds, then drops to under 500rpm and dies. It will do this several times until the engine warms up. After it warms up, the idle is fine, however, it's still is hard to start. I have pulled codes, shows nothing. I have replaced the IAC, TPS, MAP, ECT put new plugs and wires along with cap and rotor, timing checks out ok and I've also replaced the fuel filter and cleaned throttle body. After all this, I still get exactly the same thing, no difference. I now suspect a vacuum leak or EGR valve. I'm tired of spending $$$, I need help please!!!!
 

·
Registered
Joined
·
11,116 Posts
Don't spend money then. DIAGNOSE.

What code did you get when you pulled them?
 

·
Registered
Joined
·
2,393 Posts
check your timing also. hard starts never good on starter, cables, battery, and engine.
 

·
CheeseBurger Milkshake!!
Joined
·
3,760 Posts
Hook a vaccuum pump up to egr valve while the engine is running. With only a couple inchs of vacuum the engine should stall or barely stay running. Doing this will also check the diaphragm inside the valve--if the egr valve doesn't hold vaccuum, replace it.

Pull codes again, this time do KOEO, KOER, and a cylinder balance test. Check manifold vacuum--what is your reading.
 

·
Registered
Joined
·
11,116 Posts
SHOWED NO CODES
Our EEC's don't give NO CODES unless the EEC itself has something wrong with it, or you didn't do the test right.

If you get a SYSTEM PASS code, it's still a code.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
I'm not a complete idiot when it comes to mechanical issues, I'm on here looking for some suggestions and help, not criticism from individuals who think they created Broncos and know everything. I appreciate all the tips and suggestions, but please, if you can't help in any way or offer any suggestions, keep remarks like "system pass is still a code" [email protected]#&*#
 

·
Registered
Joined
·
3 Posts
Hey! Check your cat, could be stopped up. My 89 did the same thing, ended up it was the cat. I eliminated it, and put a set of long tude headers on with true dual exhaust. The difference is unreal! I have read alot of threads on the cons of headers and them not doing much as far as performance gain. I completely disagree. Give it a shot, let us know.
 
1 - 11 of 11 Posts
Top