Bronco Forum - Full Size Ford Bronco Forum banner

1 - 15 of 15 Posts

·
Premium Member
Joined
·
919 Posts
Discussion Starter #1
well im having yet another problem with my bronco. i just noticed i have grease flying out of where the chrome part of the hub bolts to the rest of the hub. if i push on the "cap" i can push it in to close the small gap but i tried tightening the 3 screws and it didnt do anything. the other side is the same as far as pushing on it, so i assume its supposed to be like that. heres a pic in case what i wrote wasnt very clear

 

·
Registered
Joined
·
9,790 Posts
well im having yet another problem with my bronco. i just noticed i have grease flying out of where the chrome part of the hub bolts to the rest of the hub. if i push on the "cap" i can push it in to close the small gap but i tried tightening the 3 screws and it didnt do anything. the other side is the same as far as pushing on it, so i assume its supposed to be like that. heres a pic in case what i wrote wasnt very clear

ill be following this thread as i have the same issue, i think its wear in the groove the retaining ring sits in. does it only do it at highway speeds, cause thats what mine does. it actually threw so much grease out once that it ran the bearing dry ( i think :whiteflag)
 

·
Premium Member
Joined
·
919 Posts
Discussion Starter #3
i really dont know, i assume once it gets warm it starts slinging it out
 

·
Registered
Joined
·
9,790 Posts
i really dont know, i assume once it gets warm it starts slinging it out
wipe it all off asn keep an eye on it, mine throws the grease outand it hits the wheel on the freeway, thats how i know.
 

·
Lick my balls
Joined
·
13,029 Posts
O-Ring that seals the auto hub face is shot.
Has this only happened recently?
and or there was too much grease packed i there.
 

·
Registered
Joined
·
84 Posts
Mine does the same thing at highways speed - looks like I need a new o-ring.
Thanks
 

·
Premium Member
Joined
·
919 Posts
Discussion Starter #9
O-Ring that seals the auto hub face is shot.
Has this only happened recently?

yeah, ive owned it for 6 months but it just started this about a week ago. can you buy just the o ring?
 

·
The Anti Yam!
Joined
·
22,680 Posts
behind this?
Yes

At least I hope so:toothless

I admit, I'm not an expert on auto hubs. But I did swap out a set about 15yrs ago and the basic assembly was similar.
 

·
Registered
Joined
·
2 Posts
I have the same problem, both sides. I have been wondering how to get the stupid thing off. I can't seem to get to the retaining ring. Brake job is needed soon and I'm sure the bearings need a good packing if not replacement. I found a write up but the description is vague.
 

·
MARBLE GARGLER!
Joined
·
11,877 Posts
So long as you are in there you should clean and re-pack the bearings cause that grease looks friggin' bad man-
 
1 - 15 of 15 Posts
Top