Bronco Forum - Full Size Ford Bronco Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I've scoured the internet for the answer for this issue. I dropped my stock ps pump for the saginaw with remote housing from psc. I'm 99.99% sure I've routed my hydraulics correctly. I've used multiple sources to verify this:

1. HP ps pump to HP hydroboost
2. HP hydroboost to HP gear box
3. LP gearbox to tube/fin cooler
4. LP tube/fin cooler to high mounted reservoir
5. LP hydroboost return line to high mounted reservoir
5. LP high mounted reservoir to to ps pump

-The cooler is mounted correctly with inlet at bottom and outlet at top, mounted in between the gear box and the remote reservoir.

-Air bled from system with engine off and then engine on with front raised

-Master cylinder bench bled and brakes bled properly

-No leaks

-Pushrod between master cylinder and booster is correct length with plastic washer

Here's the issue, the power steering runs amazingly smooth but the hydroboost is locking the brake pedals. When I cut the engine on, the pedal drops slightly and quickly returns to the top. When I pull the MC off, the pedal will go to the floor, but with the MC on it will only move an inch. I've bled the HB by turning to "stop" for 5 seconds but doesn't seem to charge the accumulator. Originally pulled from an 04 f350 superduty, had this same problem and then got a reman from advance. Same issue is occurring. Please don't say third time is the charm. I have to be missing something here. Thanks for your help.
 

·
Registered
Joined
·
1,509 Posts
Does steering effort change when you apply the brakes?

You say both return lines go to remote res are they separate connections to the res, not tee'd together then to res?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Does steering effort change when you apply the brakes?

You say both return lines go to remote res are they separate connections to the res, not tee'd together then to res?
No it doesn't. The steering is just as smooth even when applying the 1" of pedal movement that is allowed. No whining or tough steering.

I've got a -12 an return hose from the reservoir to the ps pump and 2 -6 an inlets to the remote reservoir from the hydro and the cooler
 
1 - 3 of 3 Posts
Top