Bronco Forum - Full Size Ford Bronco Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
everything was fine, it would open and close fine. and then it just stopped opening. its the driver side latch. passenger side latch releases just not the driver side! its a 94 xlt. if anyone has any info please help! this is my first bronco and i got it to my house yesterday
 

·
Registered
Joined
·
81 Posts
This may not apply, but is the window all the way down? Can you remove the interior access panel and open it by pulling the latch rods together?
 

·
Registered
Joined
·
62 Posts
If the rear window isn't all the way down it won't release right. You can get around this by pulling the access panel like Benni said and just pulling directly on the release rods - you cannot miss them.
If the window is all the way down pull the panel like I said and get it opened up. Look at the base of the tailgate in the middle for the release rod (goes up to the latch) and see if it is bent.
If all that is right then look at where the latch rod connects to the handle - they can be bent and not give the full pull to open if someone has reefed on it without the window being all the way down.
The rods and latch are all right on top so it is easy to get to & look at.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
the window is all the way down, ill try the access panel, i also found out the top has NEVER been removed since 1994
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
i want to thank both of you, i opened the access panel and pulled the rod leading to the latch, it opened. i guess ill look into what caused it. but its bout to rain and i had to get the bench back in lol
 

·
~*~*~*~*~*~*~
Joined
·
10,061 Posts

·
Registered
Joined
·
1,383 Posts
Another thing I found was i need to soak the latches in PB blaster and work them by a hand for a bit as spring and what not were very rusty.
 

·
Registered
Joined
·
62 Posts
Ahhh... Sackman is the master and I am but a pupil. Pics & links instead of a rambling paragraph!

In the second pic, the rod, mine had been bent (right side) so I pulled it out and bent it back - good as new.
 

·
~*~*~*~*~*~*~
Joined
·
10,061 Posts
Ahhh... Sackman is the master and I am but a pupil. Pics & links instead of a rambling paragraph!

In the second pic, the rod, mine had been bent (right side) so I pulled it out and bent it back - good as new.
LOL.

But there are 3 rods. The rod I posted just hangs. It doesn't connect to anything but the latch. So the rod you bent back was this rod

 

·
Registered
Joined
·
62 Posts
Nope, I meant that one too, but I did goof. Mine was bent where the window frame comes down on it so I just don't know the left from the right. :D

What I meant that was also bent (from trying to open w/o the window all the way down) was the handle rod, not one of the latch rods.
Here is a pic from Steve83's site - his writeups are wicked helpful!!!

http://www.supermotors.net/registry/media/160790_1
 

·
Registered
Joined
·
81 Posts
Glad we were able to help you, theres quite a few threads here that should help you in solving the real problem as to why you couldn't open it with the handle. The search function is your friend!!
 

·
Registered
Joined
·
6 Posts
I was having a similar problem. Driver side wouldn't let go unless I man handled it! Pulled the panel apart and simply took a pair of pliers and bent the driver side rod a bit to shorten it and it works like a charm. I thought about replacing the whole mechanism, but this seemed to do it for now so I will leave well enough alone.
 
1 - 13 of 13 Posts
Top