Bronco Forum - Full Size Ford Bronco Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #1
Hey everyone. I am having trouble with my 80 bronco... ive gone through like 3 ignition modules (thank god they have a life time warrenty)and the last one lasted like 2 miles and the truck backfired, flames came out from underneath and it sounded like some one shot a gun in the backseat, and that was all she wrote...I looked at the wires that go into the module and they all look good, I can't find anything that looks bad. i was just wondering what would cause me to be burning them up and how it can be fixed.
thanks
Martin
 

·
Premium Member
Joined
·
5,103 Posts
What brand are you replacing your modules with and where are you getting them? Why did you replace the first one to begin with? Give some history and whats going on and maybe we can start to help track down the issue....
 

·
Registered
Joined
·
117 Posts
Discussion Starter #3
the first module went out when i sunk the bronco in a puddle of water at tuttle, then i replaced it with an auto zone one and it ran well for quite a while and then this winter I lost 2 more in close succession.
 

·
Premium Member
Joined
·
5,103 Posts
Well.... The Zone ignition modules have been reported to fail pretty quickly. I am not saying thats it for sure, but I would start by replacing that with a Motorcraft so you know (well, have a much better idea at least) that you got one that shouldnt fail quickly without other issues causing the failure other than its a Zone module......

PS. Did you test the module and find it was bad or??
 

·
Registered
Joined
·
11,108 Posts
Don't buy crappy AZ stuff, that's your first problem.

How exposed to heat is the box?
 

·
Registered
Joined
·
117 Posts
Discussion Starter #6
well i got some bad news...i just went and had it test...and it was ok. so where should i look. I don't think that it could have gotten too hot because its mounted on the fender well and from cutting out my fenders I still haven't fixed them so it probably gets plenty of airflow.
 

·
Premium Member
Joined
·
5,103 Posts
Hey everyone. I am having trouble with my 80 bronco... ive gone through like 3 ignition modules (thank god they have a life time warrenty)and the last one lasted like 2 miles and the truck backfired, flames came out from underneath and it sounded like some one shot a gun in the backseat, and that was all she wrote...I looked at the wires that go into the module and they all look good, I can't find anything that looks bad. i was just wondering what would cause me to be burning them up and how it can be fixed.
thanks
Martin
Can you tell us what the actual issue is then? It sounded like you had a bad ignition module and wanted to know why they kept going bad.... Also, did you get it tested hot (warm the truck up or have them test it multiple times) becuase when the IMs go bad, they dont always just die. Sometimes they randomly give you problems...

Any ways, you wrote that the truck backfired and that was all she wrote. Is that as in, the truck is not running??
 

·
Satyr of the Midwest
Joined
·
17,734 Posts
Usually the only thing that kills ignition modules is bad spark plug wires. Check those and your coil.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #9
i didn't have another ignition module at home and had to wait until i got somewhere to get it tested and at the time i had not tested it and the way it was acting i automaticly thought that the module was out. they tested it like 20 times and it passed every time. when i go home this weekend ill hook it up and see if it works...i was also told that i might have broke the timing chain but since i wasn't romping on it i don't think that that could happen, but i don't kno. it wasn't getting any fire eccept when i turned the key on and when i turned it off.
 

·
Crusher Mike
Joined
·
6,115 Posts
Also Check your EGR thats exactly what my friends bronco did when the EGR when bad. we also thought it was the ignition mod
 

·
Registered
Joined
·
117 Posts
Discussion Starter #11
not to sound too stupid (or offend anyone)but what does the egr valver have to do with not having any fire...i thought that it just delt with exhaust gas recirculation...i don't know for sure tho
 

·
Crusher Mike
Joined
·
6,115 Posts
not to sound too stupid (or offend anyone)but what does the egr valver have to do with not having any fire...i thought that it just delt with exhaust gas recirculation...i don't know for sure tho
IT acts as a plug if it doesnt open properly it will kill the motor.
 
1 - 13 of 13 Posts
Top