Bronco Forum - Full Size Ford Bronco Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Newbie to this forum here. I would like to start off with, I'm a avid Ford man. I've owned two BronoIIs, two FSBs, and currently own a 91 F-250 7.5l and a 91 FSB 5.8L. I'm just saying I love Fords and Broncos and I love this website.

Problem: 1991, 5.8L, 4WD, Auto

Ok so I've been working on this problem for about a year now. It's sluggish off the line sometimes, I give it full throttle and it bogs down and sometimes backfirers into intake. (Remember this problem is very intermitent) Normally after doing it for a few seconds it goes away and vrooom full power again.

Somedays it's worse than others. There are times where it will bogdown backfire and the more throttle I give the worse it gets. shut the truck off start back up and same thing bog down no power and backfiring. and when I say no power i mean none truck won't move in gear. (that reminds me 99% of the time it only acts like this in gear, if i put it in neutral hit the gas it revs right up. ten minutes later I'll start the truck and it'll be fine.

other days I don't even notice it and it runs great.

Now that the cold is here it's worse than ever I can't even drive it. It's unsafe.

Here's what I know. I've pulled codes and nothing. and I know the code thing works I've used it in the past for a map sensor fail. checked compression.

I've replaced - PCV, fuel pree regulator, sparkplugs, wires, personally rebuilt distro, cap and rotor, fuel filter, idle air control valve, tps, air filter, fh relays

I've ohmed checked the tps, map, egr,

I pulled the fuel pump put it directly on a battery to see how it runs and it seem to run great.

I really appriciate any help. I'm stumped

Matt
 

·
I scrape on both sides
Joined
·
3,035 Posts
I'd eye more closely at that fuel pump.... however, you could probably run a cylinder leakdown test too just for kicks

btw i pass through vacaville on a pretty much weekly basis, so if you dont have an air compressor/leakdown tester i can bring mine over
 

·
Registered
Joined
·
263 Posts
Newbie to this forum here. I would like to start off with, I'm a avid Ford man. I've owned two BronoIIs, two FSBs, and currently own a 91 F-250 7.5l and a 91 FSB 5.8L. I'm just saying I love Fords and Broncos and I love this website.

Problem: 1991, 5.8L, 4WD, Auto

Ok so I've been working on this problem for about a year now. It's sluggish off the line sometimes, I give it full throttle and it bogs down and sometimes backfirers into intake. (Remember this problem is very intermitent) Normally after doing it for a few seconds it goes away and vrooom full power again.

Somedays it's worse than others. There are times where it will bogdown backfire and the more throttle I give the worse it gets. shut the truck off start back up and same thing bog down no power and backfiring. and when I say no power i mean none truck won't move in gear. (that reminds me 99% of the time it only acts like this in gear, if i put it in neutral hit the gas it revs right up. ten minutes later I'll start the truck and it'll be fine.

other days I don't even notice it and it runs great.

Now that the cold is here it's worse than ever I can't even drive it. It's unsafe.

Here's what I know. I've pulled codes and nothing. and I know the code thing works I've used it in the past for a map sensor fail. checked compression.

I've replaced - PCV, fuel pree regulator, sparkplugs, wires, personally rebuilt distro, cap and rotor, fuel filter, idle air control valve, tps, air filter, fh relays

I've ohmed checked the tps, map, egr,

I pulled the fuel pump put it directly on a battery to see how it runs and it seem to run great.

I really appriciate any help. I'm stumped

Matt
Please forgive my asking, but this is the Noobie section and you did call the code reader a 'thing'. Did you run the complete scan test? KOEO, Timing Advance check, and KOER.

With all the things that you've done and with the symtoms you have (truck won't move in gear) I simply can't believe that you don't have any codes what so ever. Is your reader actually returning 11,10, 11?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #6
Jason: I appriciate your offer, I may have to take you up on it someday for another set of eyes. I've done a leakdown check, but what is funny is there are times that it will do the hesitation problem for 15 sec or so then drive normal. Once it's driving normal it'll stay normal until I let off the gas or go to idle. so I beleive it has to be something electrical. I ordered a new pump I'll try it when it arrives.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #8
Please forgive my asking, but this is the Noobie section and you did call the code reader a 'thing'. Did you run the complete scan test? KOEO, Timing Advance check, and KOER.

With all the things that you've done and with the symtoms you have (truck won't move in gear) I simply can't believe that you don't have any codes what so ever. Is your reader actually returning 11,10, 11?
I realize I called it a "thing," how newbie of me. I apologize. LOL.:doh0715:
I pulled codes a while ago and remember nothing important I'm going to pull them again tonight.

I'm also going to record a video of it to paint a better picture. I will be posting it in a few.
 

·
Premium Member
Joined
·
23,549 Posts
how many miles on it?

passes smog?

I wonder if your EGR valve is sticking open.
 

·
Premium Member
Joined
·
23,549 Posts
disconnect your cat. Sounds like it may be plugged up.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #15
So I pulled codes again, got 14,62,87

14 pip sensor circuit failure - I've chaged the dissy and no difference

62 ?

87 - primary pump cicuit failure - I've checked the wiring at the pump it has good voltage. I checked resistance and got good ohms.

Please help
 

·
Premium Member
Joined
·
23,549 Posts
put a fuel pressure guage on your fuel rail. should see 40psi with the vacuum line disconnected engine running.

PIP? you said you rebuild the dizzy, but what about the TFI?
 

·
Premium Member
Joined
·
23,549 Posts
read my post again. ;)
 
1 - 20 of 23 Posts
Top