Bronco Forum - Full Size Ford Bronco Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Well i picked up my new pronco project a week back or so and i got it home to find it leaking coolant. Well i finally have got some time to work on it and i think i may have found the source for my leak. I'm hoping its just this missing bolt (simple fix)and maybe a new gasket on the water pump. here is a picture to help, let me know if you think its just the bolt missing or if i need anything else to fix or look at.


the heads have been overhauled by the previous owner so im just thinking they forgot to put the bolt in.

 

· Registered
Joined
·
22 Posts
Discussion Starter · #10 ·
hmm interesting. i will have to tear it off the next i get to it. i'm draining all fluids and startn fresh so i just need to get the leak found out before i drain all the coolant. havnt checked the oil yet. hoping for the best, since the truck has only been driven once in the last 3 years. could just be old age
 

· Registered
Joined
·
22 Posts
Discussion Starter · #12 ·
Well i got to ripping apart the motor to investigate whats up with it. Drained the oil, and its solid black, so no coolant going in the oil so thats good. Drained the cooling system and removed the water pump so i could get a better look at it. The Bolt that was missing seems to be broken off in the hole i have circled in the picture. so im going to have to deal with that. any good suggestions?

Also the crack along the edge of the block and water pump mounting area, is that 2 seperate pieces? or do i have a cracked block. because im perty sure thats where i found the only leak source. So im just hoping maybe some of you mechanical guys have any great suggestions to fix it. RVT the crack and bolt hole?. If im dead in the water i got a guy nearby with an 89 302 with 115k on it running mint for $200, incase itd be better for me to just swap the engine out.


any help would be awesome! and get my project moving along

 

· Registered
Joined
·
22 Posts
Discussion Starter · #14 ·
I'm planning on trying to get this fixed and get it running this weekend. Any help/extra info you guys could give me would be great!


i dont mean to be anoying about it, just a yound bronco/engine noobie trying to learn more:beer
 

· Registered
Joined
·
22 Posts
Discussion Starter · #17 ·
thanks for the info guys. Yeah i planned on taking the t-cover off to get a better look and to inspect/replace it, since i dont know its history. while i have the motor apart i might as well

I was thinking easy-out as well, but it seems to be broken off a ways into it, so im not sure i can get one in there. Now that crack i can see next to the block, is that just more than likely from the bolt not holding it tight or is it worse than that. I guess im just not firmiliar with the block, in if thats built into it or that the part the water pump is mounted is a seperate piece.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top