Bronco Forum - Full Size Ford Bronco Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,564 Posts
Discussion Starter #1
I have a 6 inch lift installed. (And yes I searched on this) I have noticed at certain times that I get a pop noise when body flexes slightly. What it is, is at different times it will be my front springs moving slightly where the spring sits on the Lower Spring Seat. I looked and it seems like the Retainer that goes inside the spring to hold it down doesnt hold it good enough. It will not let the spring out but the spring moves sometimes or has a little play side to side or front and back. Also have noticed that the rear springs will make the same kind of noise everonce in a while. I have add aleafs in the rear. It drives fine and have no other troubles, but the noise is nasty sounding sometimes. Is this something to worry about or is it just something you deal with, with a lift.


:banghead
 

·
Registered
Joined
·
1,564 Posts
Discussion Starter #3
Figured out what it was. On my left front spring the clip at the top as not hooked on the backside around through the hole. It was allwoing the spring to move just a little enough to be noisy. I removed it and put it back on correct and it seems to have fixed the problem. We will see as the days go by. As for the back I guess its just those cheap add a leafs flexing together is causing the sound in the rear. One of these days Im gonna fork over the cash and get full 6 inch springs for the rear.

:mad:
 
1 - 3 of 3 Posts
Top