Bronco Forum - Full Size Ford Bronco Forum banner
1 - 20 of 125 Posts

·
Registered
Joined
·
543 Posts
Discussion Starter · #1 ·
I have a 1995 XLT with the 5.8 motor. Only has 107,000 miles. Not that bad for a 1996 right? Anyway. The truck is fast as hell on the street and has a ton of power on the rocks and general driving but when I want to go up a long hill or a grade the thing is a dog. Sometimes it will make some strange ping or knocking sound, sometimes it will sputter and sometimes I have had it backfire through the intake.

Went to some dunes in Mexico this weekend to play around. Took air fromt he tires and still had 20 pounds in each. Put the truck in first and tried to go up a dune and it just doesn't have the power.

Anyone know why I can have so much power every other place I drive but the big hills and grades just turns my truck into a POS?
I have 3.73 gears and 31's right now also.

I am just wondering if I need new injectors or some other part for the motor. I "expect" the truck to power up anything with in reason.
 

·
Registered
Joined
·
543 Posts
Discussion Starter · #4 ·
No. I thought the only time it would give me codes is when the check engine light came on. Never thought about checking for any.. Quess thats a good place to start. I just want to take a mechanic form Ford and drive him up a hill and show them what it does. I hate it.
 

·
Registered
Joined
·
2,445 Posts
Chris, Is it when you are going up any hill or just a sand dune? Sand is an intresting substance to wheel in. It is all about wheel speed. Uphill in the sand I usually have it in 4 hi and manually shift the tranny from L1 to L2 to D to keep the RPM's on the engine high and the wheels spinning only letting off if they bounce really bad (axlewrap).
 

·
Registered
Joined
·
2,445 Posts
:scratchhe I'm gonna have to think about that one. Tranny full? Fuel pressure good? Let us know what codes come up.
 

·
Registered
Joined
·
2,387 Posts
mine did the samthing, this is what i did

ing. up garde (msd coil/wires and cheap plugs .55 gap)$80
castco cat. $200 = 120 for labor
fuel pump (well on mine it help)
fuel filter

hope i helped
 

·
Registered
Joined
·
2,445 Posts
abra said:
mine did the samthing, this is what i did

ing. up garde (msd coil/wires and cheap plugs .55 gap)$80
castco cat. $200 = 120 for labor
fuel pump (well on mine it help)
fuel filter

hope i helped
Plugs, wires, and rotor! Good call!:rockon
 

·
Registered
Joined
·
462 Posts
yeah ok, any one think to check the cat, especially after a little bit of a climb and then it starts to crap out. probably the cat is starting to get plugged, and its not hot enough during normal driving to effect it, but when you load it up on a hill it gets hot and the crap expands enough to plugg it. that will make it ping, and back fire outthe intake. short of changing it or gutting them, i have no way for you to check em unless they rattle.
 

·
Roller rockers are gay
Joined
·
19,547 Posts
Azkkn said:
yeah ok, any one think to check the cat, especially after a little bit of a climb and then it starts to crap out. probably the cat is starting to get plugged, and its not hot enough during normal driving to effect it, but when you load it up on a hill it gets hot and the crap expands enough to plugg it. that will make it ping, and back fire outthe intake. short of changing it or gutting them, i have no way for you to check em unless they rattle.
if this was the case, it would happen whenever he went WOT. not just going up a hill.
 

·
Registered
Joined
·
280 Posts
Well bro I hope you find your problem..............Cuz if you are talking about the dunes near Puerto Nuevo, your BKO hould be flyin around those.
I'll have to go with the restricted exhaust or plugged fuel filter thing. Even tho I would think you would feel it lag when gettin on it hard on the street.
 

·
Registered
Joined
·
537 Posts
I have that same problem, when i take my truck snowboarding i top out at 45 :shocked on some of those hills!!!
 

·
Registered
Joined
·
543 Posts
Discussion Starter · #16 ·
Good tips.

I have a brandnew fuel pump. Also put a new fuel filter in. Just had the tranny cleaned, new fluid and a new filter. New plugs and new cap and rotor. Same ford wires. and I also have a MSD coil....

When I am on the street (flat) and some grades and hills that aren't huge the truck is fast as hell. It's just going up a longer grade that kills me.
The truck will start to climb, shift into 2nd and still be doing ok and then in 3rd it cant go up. So i have to shift back to 2nd. Even flooring it doesn't power up the hills.

Same thing when I go to the desert (for those in San Diego you know the roads) The grades to get there make it so it just lugs up sometimes or I have to force it in a low gear and then have big RPM's.

As for the dunes in Mexico, I did fine all over untill I wanted to go up the "hill climb" part. Had about 20 psi in the tires, 4x4 high and put it in first and I could only make it half way because I just didn't have the power. But then every other POS at the place was just going up. Pissed me off something fierce.

Maybe I should just see if they will pull the codes and go from there. Only thing I can think of is the motor isn't getting enough gas or some stupic sensor is bad.
 

·
Dead Horse
Joined
·
5,939 Posts
when you say same ford wires, you arent talking about the originals are you? i would upgrade to a 8.8 to 9mm wire to get the power from the coil to the plugs.

what shape are your cats in? i just cut my second one off, and i noticed a big power gain.

ive towed up some decent grades with my 302 in 3rd gear, and really never had a problem
 

·
Registered
Joined
·
543 Posts
Discussion Starter · #19 ·
The wires are just aftermarket from ford. NOT the factory wires. And I think I can rule that out because of the huge power I have all the time but the big grades.

Cats.. Humm. Maybe but then again I have a ton of power all the time. For a somewhat stock motor made in 1995 it had some nice power.

All I can think of would be maybe my 3.73 gearing doesn't like hills with 31's?
Maybe the computer isn't getting all the info to tell the injectors to give more gas?
Or maybe it's a tranny issue?

It's just lame that my Big strong truck cant power it's way up a steep grade with out huge RPM's or making some funky sounds.

I think I might to to Ford on friday and see if they will read my codes and maybe take a test drive. I just want to fix it myself because I dont have the money to pay a dealership and I would rather learn to fix everything myself.
 

·
Lick my balls
Joined
·
12,958 Posts
I would consider replacing the wires to 9mm especially if you don't know when it was replaced, but I doubt that is your problem. I think your cat may be clogged. Try disconnecting the cat and see if the insides have gotten broken or something, plus recheck your timing with the spout connecter off and make sure it is set propperly.

Oh yeah, and how does your truck do on the dunes while in 4lo ?
 
1 - 20 of 125 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top