Bronco Forum - Full Size Ford Bronco Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Just got it home last night. I have a question about the tranny. I don't know much about transmissions, and that may be a problem with ny new project. I bought a 1990 Bronce with a 351 engine and an auto transmission with push button overdrive. Don't know what the tranny is. The problem with it is it will only go in reverse. When you put it in drive, it does nothing. You can put it in 1st and the engine loads up, but it doesn't go anywhere. I tried putting it in 4x4 and still nothing. I bought it knowing that I could possibly need a new tranny, but could anyone tell me if there is something I could try first before starting to pull the transmission? I'm sure it will have to come out, but thought I would ask. Any help would be appriciated. BTW...I have always wanted a full size Bronco. I am a proud owner even if I have to drive in reverse full time. If you see me going down the road backwards, just honk. Don't flipp me the bird.
 

·
Too poor for FSM
Joined
·
1,395 Posts
Welcome to the site :thumbup

as for the tranny, if your OD is push button you have an E4OD.
It shifts electronically, not by vacuum so i think your best bet would be to pull codes.

I know nothing about the E4OD, but i would start with that.
My post is a bump at least.

Good luck,
-Vance
 

·
Driving Stuff Henry Built
-90 xlt, 351w, e4od, man 1356, 3.55, sag, warn hubs, 35s. -73, 400, np435, d20j twin, 35s
Joined
·
8,067 Posts
A 90 with a 351w normally has an e4od trans behind it. The pushbutton O/D override also points to it being an e4od. Adrianspeeder has the more info in this thread: Bronco Tranny and T-Case Info

Stangmata has a thread on diagnosing e4od trannies here: E4OD Diagnosis Thread
 

·
Registered
Joined
·
4 Posts
This may be irrelevant but mine did the same thing before I had it completely rebuilt (which is near identical to what you described as yours - same year model, same push button, same size engine, if it's green then same color...). According to the mechanic who rebuilt the transmission, he said that the gear box had wobbled loose and some debris got into the gears, which messed them up. He showed me some of the gears that came out of mine, and several were missing a large portion of their teeth.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
Thanks for the info everyone. I'm sure I will have more quwstions before I am finished with this thing.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
Just found out that I have no gauges that work. Looks like it may have some electrical problems. Hopefully, the tranny will start working when I get it all straight.
 

·
Premium Member
Joined
·
83 Posts
Anything to do with the E4OD, you should call the guys at Suncoast transmissions for their HD upgrade kits and their HD torque converters. They have shops all over the US. Also add a Transgo Tugger Shift Kit to any rebuild.

www.suncoastconverters.com
 

·
Registered
‘90 EB Full Custom build -Mega Truck Bogger
Joined
·
536 Posts
Question...I am assuming you have a column shifter since you have an auto tranny.... and you did try putting it all the way down in first gear manually...right? If your fluids are good you should be able to shift manually....I hope what happened to me doesnt happen to you..but a similar situation I was involved in cost me round $900 for new planetary gears and labor...but a buddy of mine had some switch fail that told it to shift gears but the mechanic was $1200 into it before he found it....good luck
 
1 - 9 of 9 Posts
Top