Full Size Ford Bronco Forum banner

201 - 206 of 206 Posts

·
~*~*~*~*~*~*~
Joined
·
9,822 Posts
Discussion Starter #201
Today's lifetime first; I pulled the keys out of the ignition of a drunk @ss driver after following him for about 4 miles watching him have ABSOLUTE NO CONTROL over his vehicle. This was 8am, there were children everywhere waiting for school buses.....

After being on the phone with 3 different police departments someone had to stop this guy. Because 4 different citys like connect all at the same corners, that's why I was patched through to the next city. I'm like "SOMEONE GET THIS GUY OFF THE ROAD AND QUIT SENDING ME TO THE NEXT CITY, HE'S GOING TO KILL SOMEONE!!!!"

Got lucky when he went the wrong way into an apartment complex and was face to face with another car and that's when I noticed his passenger window was down. He backed up over the median to let that car through. I went ahead and pulled in front of him to stop him from going any further. I got out, reached in and turned the car off put it in park and removed the keys. The smell of alcohol was overwhelming. Took the cops another 10 mins to show up....:doh0715:

All the maintenance guys for the apartment complex were right there like WTF is going on? They seen him going the wrong way then backing up over the median.

Crazy morning it was... yeah I could of been hurt or killed but seeing all the kids waiting for the bus at numerous locations he's past was even more important to get him stopped.
 

·
~*~*~*~*~*~*~
Joined
·
9,822 Posts
Discussion Starter #204
Today, I've seen something I've never seen before!

1989 Ford Bronco. Running like crap. Guy had a mechanic do a tune up to it. Said it's got new cap, rotor, wires and plugs.

I timed the motor so i knew that was correct. Found a few vacuum leaks, started running better. But something was still amiss. Seems to run good when not at an idle. But would stall out when put into gear. Fuel pressure was within specs. 40psi KOEO and 32psi KOER and would rise. Hmmm. Shouldn't be the fuel...

Seems like something ignition. Let me pull out my timing light and check every wire with the strobe. Wow... not consistent. Next wire.... not consistent. Next wire..... not consistent.

Is my light bad?

Try on another truck. Strobe was consistent....hmmm. not my light.

Had a spare coil. Put it on. Better, more consistent but still had gaps of no light.

Start thinking, ignition module or PIP. Had my buddy call around for a distributor. While he's calling, I'm pulling wires. Pop the cap..... "Hey, forget the distributor..... it's not the problem....






Ummm yeah that just happened. 4 / 6 Cylinder rotor in a V8 distributor.

This is why I trust NO ONE with my truck!

Oh new rotor? Why is this one cracked? Why do the wires like they were cleaned?

Again, trust NO ONE!
 

·
Premium Member
'95 XLT: 5.8/MAF/E4OD/6" lift/4.56's/33x12.5x15
Joined
·
35,220 Posts
And this is just another instance among many that emphasis the reason so many of us work on our own rigs and why this site is so important to us... above and beyond the considerable comradery . Thanks for sharing @sackman9975
 
201 - 206 of 206 Posts
Top