Bronco Forum - Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6,177 Posts
Discussion Starter #1
Maybe one of you guys knows the answer to my situation.

I have a client who uses a DOS program to keep her customers' invoices together. She wants this program to print from a USB printer. How it was set up was this:

The printer was shared on the network, but since there was no network a Microsoft Loopback Adapter was installed to simulate one. In CMD when "net use" was typed it would show that LPT1 would print to \\Computer\Printer and that PERSISTENT:YES so that it would not lose the configuration. This worked fine but a few days ago her registry became corrupt and so we backed up her data and reinstalled windows after checking the drive for sector errors. Everything is back where she needs it to be, but this DOS program (or DOS itself, when typing "dir>LPT1" or print test.txt {a self-created test file}) will not print to this printer anymore. It DOES spool up, and shows in the que that it is "printing" but never goes past that...it just stays in que.

I've checked the firewall, it's allowing 192.168.1.1 (the loopback address) to communicate freely.
I've checked to make sure the printer was named correctly, it is.
I've checked to make sure LPT1 was not being used by another printer. This also checked out fine.

Everything was as it was before the registry crash. What am I missing? Why won't this print?

I have checked the printer with Microsoft Word, it indeed DOES print.

:banghead
 

·
Registered
Joined
·
11,108 Posts
I've checked the firewall, it's allowing 192.168.1.1 (the loopback address) to communicate freely.
Trying to understand what you said, but if you're trying to get the computer's loopback address, shouldn't you be using 127.0.0.1?

Though it doesn't make sense, because if it prints from Word, it should work.

What data option is set up with the printer? AFAIK, RAW is the only one that should work with DOS.
 

·
Registered
Joined
·
6,177 Posts
Discussion Starter #3
Trying to understand what you said, but if you're trying to get the computer's loopback address, shouldn't you be using 127.0.0.1?

Though it doesn't make sense, because if it prints from Word, it should work.

What data option is set up with the printer? AFAIK, RAW is the only one that should work with DOS.
I should have said the loopback adapter address, not the network loopback. Basically it's a "fake" network so the printer can be shared.


I'm unsure of what type it's set up for, I do know that it was working before. Maybe it's more of a driver issue..? I tried it here as well, but since we have a network here all I did was share our printer (similar to hers but a different model number) and set it as LPT1 and it also did not print. I'm thinking I just missed something, but I can't figure out what.
 

·
I see Broncos
Joined
·
6,010 Posts
Have you tried to remove the printer and it's drivers then reinstall it? I didn't see that step above.
 
1 - 7 of 7 Posts
Top