Bronco Forum - Full Size Ford Bronco Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
4,993 Posts
usually when lights do not work, esp. on 12 v, its a ground...you are getting power to the fixture....now may be a good time to do what a lot us have done..get the dome/map light set out of newer F150- or Mustang....better yet, get with Steve 83....he has a bunch of em......great guy to deal with....
 

·
Registered
Joined
·
172 Posts
Opposite Problem

I have the opposite problem in and 1984 XLT. Map lights work Dome does not...
 

·
Registered
Joined
·
231 Posts
Chech the plug in the dome light harness by the drivers seat belt mechinism under the trim panel. The wires are known to get "green" and break there.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
If the dome works though shouldnt they all be getting power? When I took it apart i only saw two terminals which I assumed were positive and negative.
 

·
Registered
Joined
·
1,470 Posts
Funny, I just had the same thing crop up on mine. Dome light works, but the map lights do not. hummmm???

BTW, this is my 1000th post!
 

·
Registered
Joined
·
1,862 Posts
Blue'87GT said:
Funny, I just had the same thing crop up on mine. Dome light works, but the map lights do not. hummmm???

BTW, this is my 1000th post!
it says 1001.....?
 

·
Registered
Joined
·
1,511 Posts
my map lights work, but after you turn the switch on for a few seconds. it has taken up to a min for them to turn on. which is kinda annoying. as the person using forgets about it and driving down the road at night and the damn thing turns on.
 

·
Registered
Joined
·
1,470 Posts
Streetgang said:
it says 1001.....?
I guess all posts change the number as you add to other threads. Check it now to see?
 

·
Registered
Joined
·
3,150 Posts
Steve83 said:
No, the dome is fed thru the door switches. The map lights are on constant power. The 2 terminals are the 2 power feeds - the 3rd screw is ground. The 1st thing to check is what Chris said: the dome light harness below the driver's shoulder belt reel.
My 89 map lights only go on when the parking lights are on. maybe he should turn his lights on as well for the test.
 

·
Registered
Joined
·
1,470 Posts
Steve83 said:
No, the dome is fed thru the door switches. The map lights are on constant power. The 2 terminals are the 2 power feeds - the 3rd screw is ground. The 1st thing to check is what Chris said: the dome light harness below the driver's shoulder belt reel.
I guess I need to get in there and check things out. What really makes it interesting with mine is that I just installed this dome light about a month ago from a donor truck, and it worked great at first.
 

·
Registered
Joined
·
3,150 Posts
I believe mine came from the factory like that since I havet found any wires that seemed out of place.
 

·
Registered
Joined
·
1,470 Posts
Funny, mine were on when I went out to the truck this morning, and the housing was fairly warm too. Guess I left the switches in the "on" position when I tried them out last time. They're working fine now.
 

·
Southeast Utah Native
Joined
·
919 Posts
Steve83 said:
Then it's wired in wrong.
My 89 is the same way, the map lights only work if the headlights or park lights are turned on. My wiring diagrams show this to be correct.
 
1 - 14 of 14 Posts
Top