Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Looking for a great mechanic in the Denver area. have a 2 1/2 inch lift and had some front end work done but it still is all over the road. Also runs horrible after rebuilt engine install.

thanks,

Matt
 

·
Premium Member
Joined
·
1,253 Posts
Welcome Matt! I live in Broomfield and work in Brighton. Been driving my 88 E/B back and forth to work since 2007 when I moved where I'm at now. Skip @ Brighton Auto has been taking care of my 88's major needs. The owner of this place owns 3 Bronco's! You can see a couple of them if you go thru their website. My 93 E/B had a 4" lift installed on it when I bought it. They put all the lift stuff in over a trashed out suspension. It needed ball joints, tie rod ends, a pitman arm, and shocks . After all that was replaced the steering box needed to be tightened up. Sounds to me that might be what you might want to start looking at. If the box can't be dialed in there are all kinds of post's here you can find about the Red Head steering box replacements. Best of luck, Brian:thumbup


http://www.brightonautobody.com/
 

·
Registered
Joined
·
26 Posts
hey bmad01 I am a Newbee
I just purchased a 86 from crags list and live in broomfield do you know a good mechanic that can just check mine out? It has a miss and slight oil leak, Thanks !!
 

·
Premium Member
Joined
·
1,253 Posts
hey bmad01 I am a Newbee
I just purchased a 86 from crags list and live in broomfield do you know a good mechanic that can just check mine out? It has a miss and slight oil leak, Thanks !!
Hammer, congrats on the buy! I'm not sure what to tell you. You've bought a 33 year old vehicle. That's a long time and who knows what kind of life it's had. How many miles were you told it had? I got my 88 in 2004 with 80,000 miles on it. It's been my daily driver to work and back since. It just turned 218,000 miles. All this time I've been taking care of it and fixing whatever I can myself. In December I had the AOD trans rebuilt for the second time. In January it got a complete brake job with all the fixins. Rotors, Pads, Hubs, Brake drums and shoes. It's been an expensive new year, but it's running just fine. Just had the oil changed yesterday on the way home. Been doing that every 3000 miles since I got it. The list of shit I've replaced is very big, but I buy parts with lifetime warranties and I use em!
Anywhere you take it is going to cost you a minimum of a hundred bucks just for labor. You say it got a miss. Have you pulled the distributor cap off and had a look inside? How do the plugs look? How do the wires look? How does the air filter look? Are you carbed or fuel injected? All the parts I just mentioned you can buy and install yourself and save a ton of cash. I'd start looking there first.

The shop I mentioned above does the work I can't do myself at home. I've had them put on 2 timing chain covers, a new gas tank, new fuel pumps, and brakes. I'm thinking my radiator that's 3 years old is leaking now, but I'm not all twisted up about it. It's a lifetimer from Oreillys and will only cost me time and anti freeze.

You catching my drift? If you run into problems this website is the shit! You can use the search function and find an answer to any Bronco question you can drum up! There isn't any shop In Broomfield I've ever used and liked enough to tell anyone about.

My 93 E/B failed the smog lanes last year. I went to a shop about 2 blocks away from the lanes the lanes suggested. I had run codes myself and found it had a vacume leak. I went to this shop and told the mechanic what the code was and showed him the diagram of the vacume lines on the bottom of the hood. I go to pick the Bronco up and find the bill is almost $400.00! WTF??!! He fixed the vacume leak and ran a smog test himself and it failed! Then he tried to sell me $1200.00 "custom made" catalytic converters after telling me he needed $600.00 deposit to order them. I paid the $400.00 bill and got the f**** otta there. The next day I fired you the Bronco and let it run for 5 minutes before leaving. I drove it for 25 miles all over hell and back. Then I went back to the lanes and had it tested again. It PASSED!:histerica

Most of the work you can do yourself! Good luck!:thumbup
 

·
Registered
Joined
·
26 Posts
Bmad01, sorry for the late response. The miss was a spark plug wire not attached-Crazy now it rounds great results-did vacuum lines and some other things not it is running great an oil leak has appeared but just still trying to get it to pass smog. The EGR is active at start up and then stops after warm up. I am getting codes 31 and 84 I have checked everything that I have read online and so far everything is working. Maybe a bad pcm? Not sure. I wish I still knew a mechanic that could listen to me and steer me in the right direction. Maybe I can register it in weld county no emissions there.


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top