Bronco Forum - Full Size Ford Bronco Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
589 Posts
Discussion Starter #1
So i was crusin up the highway here in michigan, jammin to some Allman brothers on the stareo.... doin about 72 in my moms little red Geo Prizm.... when all of a sudden KABLUOOOEEEEE!!! i hear a loud pop, then im drivin through a cloud of smoke that looks like somthin out of turn three in Days of Thunder... pulled over to the side of the road... puts it in park jump out and take a peak.... i put two rods into the oil pan, im guessing two by the number of dents in the pan... big dents... and then i see a crack in the block of her little 4cyl...

needless to say... MOMS not happy. and when moms not happy.. no ones happy. i wasnt even screwin around. no one believes me i was just crusin to work on the bronco.

got to the bronco... finished her up... started her up... let her run for a bit... jumped in... went down the road... purrs like a kitten... get out on the big road... get on her a little bit... Fawkkk shes not shifting outa first gear... rebuilt tranny not shifting? get back home in the parkin lot.. jump out... looked at the tranny everything appears to be hooked up... open the hood for shts and giggles, rain stars falling, noticed my battery was erupting like old faitfull? WTF... i take that battery out... put in my good heavy duty battery... nothing. not a sound. whatever happened to the other battery obviously affected more than just the battery. (insert ideas of help here)
so not only did i kill the daily driver i was using, i killed the bronco. and its a long walk home in the rain...

needless to say its been a fun day... just needed to let it out a minute. :banghead :banghead :banghead
 

·
Registered
Joined
·
589 Posts
Discussion Starter #6
the day started good... i had to get new yolks for my transfercase and my rear axle... long story. anyways i brung my old ones in to the guy at the parts store, and he gave me what i needed for the transfer case (yolk and seal) in a straight up trade for mine that i took off. not bad i thought. and i paid half price for the new one for the axle.. both brand new yolks out of boxes... so the day was a good start. and of course my plate...

but it was after the shop on my way to work on the truck that all hell broke loose...

so 2 steps forward... and it felt like a million steps back...
oh well what can ya do... life could indeed be worse... :beer
 

·
Living in Obscurity
Joined
·
1,928 Posts
Damn dude, that is not fun! Hope your mom can get something else to drive!
 

·
Premium Member
Joined
·
10,513 Posts
and here I thought you were moving to Vermont? :shrug

blowing moms engine is truly a drag bro ... she gonn amake you pay for it? :shrug

was there any oil in it?
 

·
Retired
Joined
·
16,007 Posts
I say get the bronco running and run over the Geo. J/K sorry to hear your problems. My tranny did the same thing and it was the modulator. The pin behind it was not the right length. I had to make a new one. The cam I put in did not produce a enough vac. Also if they produce to much vac it can do the same thing. Try to adjust the screw on the end of it. Just keep with how much you adjust it so you can go back you have to. Good luck.
 

·
Registered
Joined
·
589 Posts
Discussion Starter #11
Damager said:
and here I thought you were moving to Vermont? :shrug

AHHHHHHAHHHAHHAHHH me moving? yea.. all those nice plans and everytthin was goin so well and everything was set... then in two days all blows to hell. needless to say those plans arent happening anytime soon... maybe next summer ill give it another whirl but for now... blowing up cars, and my bronco (which was my ride to vermont suposedly) is all im good for. i got my hopes up and got ahead of myself to much. now im Fawked.

but as a wise man once said any day above ground is a good one, isnt that how it goes?

and yes there was oil in the engine... now its on the highway, but there was oil in it...
 
1 - 16 of 16 Posts
Top