Bronco Forum - Full Size Ford Bronco Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,243 Posts
Discussion Starter #1
Front D-60 blew while I was going down the road... pretty sure I torn up something else... skidded across the road and barely made a side street... I'm okay...
 

·
Engineer
Joined
·
13,165 Posts
RLKBOB said:
We need carnage pics.
+1 this thread is worthless without pics
 

·
Yup, I'm fullsize....
Joined
·
1,798 Posts
:stupid
 

·
Registered
Joined
·
1,243 Posts
Discussion Starter #7
No pics. Had a f*cked up day... got worse... now they can't even locate the stuff I/they need to fix it.
 

·
scrounger extrordinaire
Joined
·
4,775 Posts
what did you get that has a D60??
 

·
Ex Navy Nuke
Joined
·
5,421 Posts
Spookshow ONE said:
No pics. Had a f*cked up day... got worse... now they can't even locate the stuff I/they need to fix it.

Who is they?

I was also wondering what you had that has a Dana 60, your sig line says it's a 79 Bronco. Did you swap a 60 onto it?
 

·
Zombie Hunter
Joined
·
13,696 Posts
RLKBOB said:
Who is they?

I was also wondering what you had that has a Dana 60, your sig line says it's a 79 Bronco. Did you swap a 60 onto it?
Nooooooooooo......the 79 ate it a while ago, i think it was an F-250
 

·
Registered
Joined
·
1,243 Posts
Discussion Starter #12
RLKBOB said:
Who is they?

I was also wondering what you had that has a Dana 60, your sig line says it's a 79 Bronco. Did you swap a 60 onto it?
They is a garage owned by my buddy.
 

·
Registered
Joined
·
1,243 Posts
Discussion Starter #14
Napa and Autozone's bearings were the wrong size. They were too small... they pulled some number and said it was bigger than the standard Dana 60...
 
1 - 14 of 14 Posts
Top