Bronco Forum - Full Size Ford Bronco Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Happy New Year all. New Guy here.

My AM reception is terrible and I was looking for recommendations on either a replacement antenna or booster or maybe a noise suppressor. I'm only 50 mi from NYC and with some stations, all I hear is the sound of the engine. I bought an electric antenna but quickly discovered why it wasn't on there from the factory....there is no place to put the thing! :banghead Any ideas?

Also, when trailering my 16.5' Alumacraft with 75 HP outboard, the truck seems a bit twitchy. Not out of control, but just nervous. My '01 Sequoia pulled it like nothing was there. Any recommendations for stabilizers or something to settle it down? I know a short wheel base doesn't help, but I can't imagine feeling comfortable pulling something really heavy.

Thanks!
Mike
 

·
Registered
Joined
·
1,078 Posts
mine pulls fine. we pulled a 30 foot travel trailer with it. only thing we did was add rear overload coils to keep the rear end up high.
 

·
In The Matrix
Joined
·
1,896 Posts
Make sure your factory sway bars are still there, if maybe a previous owner took them off? You could also add an air bag in the back to help make it stiffer.
 

·
In The Matrix
Joined
·
1,896 Posts
ooops

As far as the radio, any cd-player I have had in there has had crappy reception, AM or FM. Up in the mountains, about 50 miles from denver it starts to get really bad, where my dads truck (98 cummins) picks it up clear. I suppose the factory antennas are to blame, as far as replacing them with what, I don't know.
 
1 - 5 of 5 Posts
Top