Bronco Forum - Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
334 Posts
Discussion Starter #1
Hey people. I have a 89 EB Bronco, with a 5.0, 71,000 miles. It sat for 6 years. I got about a week ago. It runs about 45 to 50 p.s.i while running. As soon as I come to a stop the pressure drop's to 0. No Knocking or anything. And only after it has warmed up. I don';t think that it's the oil pump, I'm thinking maybe the sending unit.
 

·
Registered
Joined
·
14 Posts
you need to verify oil pressure with a mechical gage,then if still no pressure an engine that has sat that long and wasnt properly put in storage could have forign material in the pick up screen of the oil pump pick up tube....Just a thought
 

·
Registered
Joined
·
334 Posts
Discussion Starter #3
Fixer said:
you need to verify oil pressure with a mechical gage,then if still no pressure an engine that has sat that long and wasnt properly put in storage could have forign material in the pick up screen of the oil pump pick up tube....Just a thought
I will give that a try in the morning. I bought a mechanical gauge 2 days ago. A friend told me they aren't reliable on 4x4's, He seems pretty stupid now doesn't he. I'll start putting my questions on here for now one. And Thanks. :chili: :goodfinge :banghead
 

·
Registered
Joined
·
20 Posts
Dude, my "92 does the same freakin' thing!!! I'll accelerate and the needle stays up, then, I let go of the gas for an upcoming stop and the needle goes down as if Ive turned the truck off! Let us know what in the world that could be, PLEASE.
 

·
Registered
Joined
·
334 Posts
Discussion Starter #5
The Guage worked

It looks like it was the sending unit. When installed the mechinical gauge it reads fine all the time..
Tomorrow I'm taking it in to have Duals put on. Then start building the motor.
I have a Supercharger to put on. I'm going with a 3 inch body lift. (only to start). Then a 8 inch suspension lift in the summer. and 37 inch thornbirds.
Thanks For all the help. :rockon :wacko :rebelflag :toothless :twak :slap :enforce
 

·
I break chit
Joined
·
4,685 Posts
Hoss92 said:
Dude, my "92 does the same freakin' thing!!! I'll accelerate and the needle stays up, then, I let go of the gas for an upcoming stop and the needle goes down as if Ive turned the truck off! Let us know what in the world that could be, PLEASE.

Me too but the mechanicla guage reads good the whole time!!!
 
1 - 7 of 7 Posts
Top