Bronco Forum - Full Size Ford Bronco Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter · #1 ·
Hi there I have had a problem forever. I had a motomaster carb on the 351m since I bought it and could never get it running right. I decided to switch it out with a Holley 350cfm 2bbl last year but no matter how I set the screws it still smells really rich and won't run well untill it is warmed up. But even when it warms up it still smells like a lawnmower (really rich) and most of the time it is spitting black out of the tail pipe......

I did a gear and chain swap last year and did not change anything.

Any ideas on what it could be.....

  1. weak coil
  2. bad dizzy
  3. bad carb
  4. anything else

This is really bugging me and I want to get it running better before the nicer topless weather is here :whiteflag
 

·
Rest in Peace Friend...
Joined
·
611 Posts
It sounds like you need to do the idle mixture adjustment. Here is a great link for Holley carbs that will give you a good understanding of how they work and how to adjust them. http://www.bob2000.com/carb.htm

Good luck,
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #3 ·
I was just doing a search on Holley carbs and I found something that might just fit my description.........

The Power Valve.........could this be my problem???????

One thing that some sites have been saying is that if there is a backfire (and I have had one right when I did the carb,,,,,,story to follow) it might blow out the power valve. In my fiddling with the carb I can get it running pretty good but it is always a rich mixture and I can never get it lean.

Anyway tell me if this could blow the valve........When I was working on the truck my buddy was helping me out because there was a thunder storm moving in and we still had to get the dizzy in and wired up and put the carb on, so I did the carb and my bud did the cap and wires.......Well when we got done (he did a TDC on compresson) I went over to start the truck and turned the key and BANG fire ball out the carb......... I checked all the connections on the carb and everything else and he double checked the wiring and all was good so I tried turning the dizzy abit and tried again and BANG another fire ball..........Well after this time I said I will check the wiring and have him check the carb (starting to thunder out) and he said that the carb looked good and I started checking the wiring...........

Well never let someone that has only wired Chebby's up do your wiring on your Ford. He by accedent, wired the plug wires up clockwise :twak Well after redoing the wires counter-clockwise the truck started up and I have been trying to set the mixture.......


I think I might have just found my problem but what do you guys think.....
 
1 - 3 of 3 Posts
Top