Full Size Ford Bronco Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've got an 86 Bronco XLT 351w w/ c6 auto. Recently bought a new head unit for it, Pioneer mvh-s310bt, and the only issue I'm having with it every now and then when I start the truck up, the head unit refuses to turn on, until I take off the radio trim bezel and fidangle around with the wiring harness behind. Only then does it sometimes power back up. Any input is appreciated. If you need any clarifying questions, ask away.
 

·
Registered
Joined
·
353 Posts
I've got an 86 Bronco XLT 351w w/ c6 auto. Recently bought a new head unit for it, Pioneer mvh-s310bt, and the only issue I'm having with it every now and then when I start the truck up, the head unit refuses to turn on, until I take off the radio trim bezel and fidangle around with the wiring harness behind. Only then does it sometimes power back up. Any input is appreciated. If you need any clarifying questions, ask away.
I mean if you say it powers on after moving the wiring harness I'd say check the connections and make sure they're not corroded and are seated properly


Sent from my iPhone using Tapatalk
 

·
Ford Hoarder
78 & 92
Joined
·
6,574 Posts
Run new power and grounds, Best would be a relay setup straight from the pos side of battery.
 

·
Premium Member
Joined
·
4,165 Posts
May not be enough voltage if you haven't did the 3g alternator upgrade. Electronics act funny with a battery is weak. Common problems on the newer fords when a battery is failing. Yours wont be a battery failure but an alternator that isn't keeping up.
 
1 - 4 of 4 Posts
Top