Bronco Forum - Full Size Ford Bronco Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hello...i bought a 92 4x4 bronco w/ a 5.0 about a little over a year ago and have driven it maybe 4 months total. every time i fix something another thing breaks it is always broke and parked. i live in indiana and work at a shop so i get things fixed it just takes forever...i need recommendations on possible problems when she acts up so hopefully i came to the right place...thanks
 

·
Premium Member
Joined
·
7,409 Posts
Welcome aboard!! :rebelflag

A few things to know:
1. Make sure to vote for FOTM each month by going to the FOTM thread and picking your fav. nominee! (5 new nominees each month, and someday it could be you!)
2. Be sure to vote for this site at TOP4x4 by clicking the link at the top of the page once a day, when you get to the TOP4x4 page, click the “vote for the site I just left” banner. (It brings us in alot of new traffic!) It also lets those “other” wheelers know what rig rules the land! :rockon
3. Post up some pics of your rig!
(click here—>click me, click me!! to find out how!)
4. Add your rig's specs (or a pic) to your sig line. (It comes in handy, when asking questions, for people to know what kinda rig their helping you with!)
5. Before asking a handful of questions please try the search button at the top right hand corner of the page.
This site has been around long enough that ALOT of topics have already been discussed and now all you gotta do is read.

Again, welcome aboard, make your self at home!!!:thumbup
 
1 - 9 of 9 Posts
Top