Bronco Forum - Full Size Ford Bronco Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
294 Posts
Discussion Starter · #1 ·
So heres the deal, I was replacing the rotors, calipers, and brakes. I managed to talk the GF into letting me get new hubs:beer

I picked up a set Mile Marker hubs and set out on my project. :twotu:





Starting out all looked good, did not take into consideration the inteliigence factor of the clerk who gave me wrong parts. After running down parts, changing this and that, I got lost on the new hubs so i shelved the new hubs till I get things figured out.:banghead

So whats the problem? How does the new hub go on? I take off the tire, the cap containing the hub comes off, then i remove the c clip and a washer that has teeth that fit the spline, then I take the big socket with prongs to remove the piece that holds on the rotor and the bearings.

So I put on the rotor and the bearings and screw on the piece with the big socket, I put the washer that fits the splines on and then the c clip. here is where I got lost, the instructions call for a 1 1/4 " clip that they dont provide and parts store didnt have any.

When i put the new hub on does it just go on the end of this existing set up, and then leave the old cap thing off, and mount the new cap on the outside of the wheel cap. Or does part of the existing set up go away. I could use some help on this
 

·
Registered
Joined
·
294 Posts
Discussion Starter · #4 ·
- you have the special '87-early 88 "flange-style" manual hub locks, which are outrageously expensive to replace & very weak.

Well isnt that special:shocked . I am so glad to find this out:banghead

So I need to find this other style hub, and when I find it make sure same style caliper as mine. then grab axles, etc. Now will my existing rotor work or am I going to need those also.
 

·
Registered
Joined
·
294 Posts
Discussion Starter · #7 ·
I thank you for your input, I will save the links, that steve83 left for me and when I am better prepared for that project, Ill look it up again. Mine work ok for now but have read that they are pretty much junk. Main issue was the rotor on passenger side was shot, as was the brake on that side. Did ok with swapping rotors, calipers etc. The hubs were just a thing to do, while i was there.

Hopefully I can do it before Spring:twotu:

Thanks again !!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top