Bronco Forum - Full Size Ford Bronco Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hello,
Nice to meet everyone here. Anyway I have a few questions about my BKO. First off its a 1980 FSB with a freshly rebuilt 400m and tranny. The mods are the following: Edelbrock air intake, Holly 600 carb, and a cherrybomb exaust. It only has 180k on body and 5k on rebuilt motor and tranny. I only payed $900 for it.
Now for the problems ,which I searched for and found a few answers. First one when I reach about 65 mph it vibrates but only if I let off the gas or idle it around that speed. Second when I switch it in reverse it pops which means “Bad U-joint” right? Third it pulls the right slighty when driving ,and when i brake it pulls to the left. So I thought sticking caliper on right so i changed it. It helped with the problem a little ,but it still does it every once in a while. My thought is I need a steering alignment or tire alignment or both. Am I going down the wrong rabbit trail or am I right?
Thanks for your time ,and any wisdom will be appreciated.
 

·
Registered
Joined
·
302 Posts
I'd check the balance of the tires for the 65mph vibration, or could be a bad belt. I worked at a tire shop for a while and it kinda sounds like that. Im sure an alignment would help, but I'd take it to a shop and just ask them to look over the front end for ya. Everything else sounds about right though!

Welcome to FSB!

(even though i dont have one, but ive had 2 :p)
 

·
Registered
Joined
·
664 Posts
I'd check the balance of the tires for the 65mph vibration, or could be a bad belt. I worked at a tire shop for a while and it kinda sounds like that. Im sure an alignment would help, but I'd take it to a shop and just ask them to look over the front end for ya. Everything else sounds about right though!

Welcome to FSB!

(even though i dont have one, but ive had 2 :p)
Bad belt? Are you referring to the serpentine belt? How could that have anything to do with a vibration or steering issue?

To the OP:
Glad to have you on board. Is your truck lifted? If the body has 180,000 miles on it, you probably need to replace the radius arm brackets and bushings. Do a quick search, and you will find some good info on this. These could also make your vehicle east to the left or right like you are suggesting.
As far as the vibration, have you checked to make sure everything on your drivetrain is nice and tight? Driveshafts etc? Just something i would look into.

Welcome to the bronco world. :thumbup
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Hey I would post a pic but my wife crashed my laptop ,so I am on my blackberry. Well I wanted to know if I was right about the u-joint problem? I arrived at my brother in laws. I drove from Cumberland, MD to Clarksburg, WV which is about 120 miles and got 16 MPG.
 

·
Registered
Joined
·
302 Posts
that i did gentlemen! although some tires don't have belts (Mine) and rides like a caddy with square wheels. Lol:red x
 
1 - 8 of 8 Posts
Top