Bronco Forum - Full Size Ford Bronco Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Newbie here! Picked up an '84 the other day, and I'm already lovin' it! Though, it is a fixer upper, and I've already found a few problems and hopefully you guys can help me out.
1. None of my gauges will light up. only the top row where the turn signals and high beams lights are light up. I've check the connector and all the bulbs are new. Could be the fuse, but the cover for the fuses is missing and all I have is the Haynes manual and that doesn't show me what fuse is what. So if anyone could help me there.
2. When I release the parking brake, my rear driver side tire still drags as if the drum is locked up????
3. Has anyone had an internal coolant leak? its the 5.0 and its leaking coolant but its not coming from any hoses or the radiator. So not sure about that.
Other than that, its not in bad condition at all. I'll post some pics soon. Any help would be really appreciated!!!
Thanks,
Bryan :drinkbud
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
Thanks man,
yea, I checked the manual over and over, but not picture. As far the the linkage, I checked it right under the seat under the truck, and the linkage releases, but the cables splitting to the two different drums don't move, so not really sure.
 

·
Registered
Joined
·
3,758 Posts
SpongerDKB said:
Thanks man,
yea, I checked the manual over and over, but not picture. As far the the linkage, I checked it right under the seat under the truck, and the linkage releases, but the cables splitting to the two different drums don't move, so not really sure.
is there tension on the cable all the time? how much? go over the entire linkage and see where it may be binding/sticking. sometimes some 3 in 1 oil can take care of things like that.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #8 ·
Not exactly sure, only from the linkage and back is there tension. Once I pull the brake, the cable up to the linkage is loose. I'll have to check into it a lil more tomorrow to see how much tension is there. Thanks again for the help! I'll let you know what I find tomorrow
 

·
Registered
Joined
·
278 Posts
heya! lol well im glad my room mate took my advice and came here! Thanks for helping him out guys :beer

i know i will definitely be helping him out fixing this up:thumbup
 

·
Registered
Joined
·
244 Posts
You say "internal coolant leak", do you mean in the cab or into the motor? Into the cab sounds like a heater core, into the engine, blown heads or bigger problems. If the exhaust smells like burnt antifreeze, it sounds like a blown head. Does it look like steam? The exhaust I mean...
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #15 ·
The exhaust smokes after be driven for a lil while, but no steam during idol. There is a steam like smoke coming from the engine on the right side near the headers. Not sure exactly what that is.
 
1 - 20 of 27 Posts
Top