Bronco Forum - Full Size Ford Bronco Forum banner

no fire, no fuel

3458 Views 16 Replies 6 Participants Last post by  BamaBronc
i have a 1988 bronco xlt with a 5.0

it just died on me one morning. i have no spark and no power to fuel pumps. i changed the plugs, wires, cap, rotor, coil, ignition control module, fuel pump relay. finally i called someone to come and take a look at it, they said the coil i got was bad and if that didnt fix the problem then i needed a new computer. i changed the coil again and changed the computer but still no luck. i'm out of ideas. when i pull my coil wire off of the cap and put a plug in it i only get one yellow spark when i release the key. my fuel pump isnt getting power. i can jump the relay and hear my fuel pump kick on so i know the fuel pump is o.k. i know at this point it has to be something small because ive changed all the big stuff.

any help would be greatly appreciated:banghead
1 - 17 of 17 Posts
Did it die after you just went wheelin or from daily driving?
You can jump across the fuel pump relay, the haynes book says how, Do you have pressure in the fuel lines, if you press down the bleeder valve above the engine does fuel spray everywhere or nothing at all.
i havent taken it wheelling in a long time. i just go to and from work. all street. i started it in the morning and let it warm up then backed out of my driveway and got about two car lengths when she died stone cold dead. it took me awhile to push the damn thing back into my driveway by myself.
yes i did jump the relay and the fuel pump kicked on and yes when i did this i had fuel pressure, but it didnt matter because i have no spark.
I had a similar problem on my F150. After changing "everything" it turned out to be the small ground wire from the negative battery cable to the computer. Check for continuity at the computer.
Run a self-test, the computer will tell you what broke:

My guess is the TFI module on the side of the dizzy. If the comptuer doesn't see the engine rotate, it won't turn on the fuel pump.

change the TFI and the stator inside the dizzy after runnign the self test
when i pull my coil wire off of the cap and put a plug in it i only get one yellow spark when i release the key
Check your ignition switch.
I would have to agree with Fireguy, it does sound like a TFI, the Broncos with TFI's mounted to the dist tended to have the exact problem you are describing, some even stalling out in the middle of traffic. Ford I believe even issued a TSB on them, not sure what the fix was.
:lolup there was no fix. :lolup
Ford got sued over the TFI and lost big time.
no fix, lost law suit, TFI is fun at best
i did have the ignition control module tested and it failed, but i changed that with no luck. i do have a code reader. i used it when this first happened and all i got was "fuel pump relay circuit failure" code. the next time i tried to use it i got no codes. the light just stays on.

i will have to try to locate the ground wire to the computer this weekend.

if the ignition switch is bad will the engine roll over?

so far i can tell you that the coil was bad and so was the ignition control module,i had both tested. i just dont see how three or more things can fail at the same time.:banghead
if the ignition switch is bad will the engine roll over?
Yes if it's bad in the on/run position, but works as it should in the Start position.

Kinda like how the heater control fan switch may work in the lowest and highest settings, but not in the middle settings.

It's not very common, but I've seen it before.

thank you all very much for your input.:D

saturday i am going to change the ignition switch and try to locate the ground wire for the computer. i'll let you know if it works.
well it turns out the fusable link going to the eec relay was blown. i jumped it off the fuel pump relay and the damn thing started right up. i cant find the actual fusable link, so i just ran a new wire from the battery to the relay. will this be o.k.?

thanks again to all of you that replied to my dillema.:thumbup
Did you install an in-line fuse?
yeah with a 20 amp fuse. i dont have any way of knowing what the proper amperage fuse would be
Good. Now that'ya got it runnin', you need to find out what caused the link to fail before something else important melts.
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.