Bronco Forum - Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
alright so i got a check engine light found out my o2 senser is bad went to change and the connector from the truck to the senser was melted to gather in a nast mess. any ideas on what to do can i just go get the connector of a junk yard truck and splice it in and hook up to a new one. or will splicing this mess with the way the senser works and the ecm reads the signal. ive been told that this could mess up the resestance or somthing.
 

·
Satyr of the Midwest
Joined
·
17,736 Posts
Depends on what's melted. If it's the connector on the truck's wiring harness, I'd say get a new one if you can from NAPA, with a junkyard being the less-favorable choice.
 

·
Registered
Joined
·
215 Posts
whatever you decide to go with, at least solder and shrink wrap the new pigtail on the harness, instead of crimp connectors.
 

·
Satyr of the Midwest
Joined
·
17,736 Posts
:stupid Yes, very good point. Thank you. :thumbup
 

·
trying to go fast!!
Joined
·
1,083 Posts
whatever you decide to go with, at least solder and shrink wrap the new pigtail on the harness, instead of crimp connectors.
:thumbup :rockon
 

·
Registered
Joined
·
215 Posts
At least I learned something in my 6 years of ASE tech classes, and 10 years of experience on top of that. Too bad I don't work on cars much anymore, since I went into the mobile electronics installation field. :)
 

·
Satyr of the Midwest
Joined
·
17,736 Posts
Yeah, and I'm pursuing my electrical engineering degree. :rofl:

Must be the AAS in automotive engineering talking.
 
1 - 7 of 7 Posts
Top